Audio issues when switching Mac speakers & headphones


This is my first post in the community, yeah!

I have been learning about VCV Rack the last couple of weeks by: (1) viewing Youtube channels [Omri Cohen, CVC Rack Ideas, VCV Rack Hacks, and many others], (2) per several VCV Community recommendations, I am reading “How to Rack” & “The Book of Bad Ideas” in pdf, and, just received the purchase of "Becoming a Synthesizer Wizard, and last (3) downloaded several patches to play around with these as I listened many videos for a 2nd time.

As I have been using VCV Rack, I ran into a problem when switching between my headphones and on-board Mac speakers, and, it happens pretty frequently. VCV Rack either freezes and/or completely crashes, thus, tried to troubleshoot a couple of things without success. I read a couple of other threads regarding audio problems, yet, those were focused on utilizing additional DAWs while running VCV Rack. My issues is if I have an open patch and disconnect my headset, VCV Rack does not recognize that, and, in some times when I try selecting it in the Audio-8 module, it still shows up as a selection though not plugged into the Mac. And, at times, the Mac on-board speakers are not shown within the selection which is very odd to me.

Anyway, if anyone else has run in to a similar issue, please let me know. For now, I have been basically shutting down VCV Rack and going back in, yet, it’s a little annoying. Thank you!


Yup. I get exactly that on my MacBook Pro, even when switching from one set of headphones to another.

Pull out or insert the plug, and I get the spinny beachball. I have to use to stop it. My work-around has been to use a headphone Y splitter, and leave the splitter in most to the time, especially since the built-in speakers can’t really do it justice.

Also, if I remember to do it, I’ll select either “MacBook Pro Speakers” or “External Headphones” before I make the hardware change. Then it makes the transition just fine. If I’m swapping out one headphones for a different pair (or an amp) then I have to do it in several steps: If, say, the headphones are plugged in and selected in AUDIO-8 at the start:

  1. Select “MacBook Pro Speakers” in AUDIO-8,
  2. pull the plug,
  3. select “External Headphones” in AUDIO-8,
  4. plug in the new device.

I suspect it has something to do with the headphone jack being under control of the “Apple T2 Bus” (USB), instead of a simple mechanical make-or-break contact in the jack that’s normalled through to the built-in speakers’ amp.

[edit] I have also run the Linux version of Rack on a Lenovo laptop with Ubuntu, and I don’t recall it misbehaving there, but I don’t use that one very much for Rack anyway.

1 Like

Thank you very much for the insights, along with the explanation as to a probable cause. Always good to know the “why”. I have a couple of Y’s around, thus, will need to put them to use. Will give that a go! Again, thank you!

p.s. BTW, on your point about Apple T2 Bus, I would then expect this issue to occur with other SW (like DAWs). However, I’ve been using Ableton (w/o VCV Rack running) in that way and do not recall having this problem.


Ableton is a big enough company that they would not be able to ship software that crashes in such a common scenario. Is this bug logged with VCV? It should be, I think Andrew would want to fix something like this (it’s probably already fixed in v2?).

1 Like

Thanks for the advice. I am completely new so, good to figure out how to connect and provide such fdbk for further the dev of a great asset. Will follow up.

1 Like

Issue/bug submitted @ GitHub (VCVRack/Rack) - Issue #1917.