anybody uses obra midi controller with VCV?

as anybody used obra midi controller with VCV, i<m quite a noob and vcv just crases when i try it, i have tried different modules and they all crased

1 Like

Is other software using the midi device, like configuration software or DAW? Usually (on Windows at least) only one program can use a midi device at a time.

I think we need more information to help you:

  • What’s your OS (Win, Mac, Linux)?
  • Does this happen on sending MIDI from VCV to the controller or on receiving MIDI from the controller?
  • What do you mean by ‘a module crashes’? Does the Rack itself crash? If so, could you please provide the error-logfile?
  • It would also be helpful to post the VCV patch that causes the problem so someone here in the community can try to recreate the error?
1 Like

I’m guessing, the Orba is sending MPE, and you have to use an MPE Midi-CV module.

Edit to add: I see now that VCV Midi-CV has MPE now.

Perhaps some tips here for MidipolyMPE

i<m using window 10, the the complet vcv crashes as soons as it detects the obra. and i have tried many differrent patches all the same. here is a error log file

[2.332 info src/main.cpp:189] Starting engine
[2.332 info src/main.cpp:201] Running window
[2.335 info src/window.cpp:72] Loaded SVG C:\Users\simon\DOCUME~1/Rack/plugins-v1/MindMeldModular/res/comp/mixer/fade-off.svg
[2.336 info src/window.cpp:72] Loaded SVG C:\Users\simon\DOCUME~1/Rack/plugins-v1/MindMeldModular/res/comp/mixer/fade-on.svg
[3.195 fatal src/main.cpp:45] Fatal signal 22. Stack trace:
28: ZN4rack10appDestroyEv 0x456435
27: raise 0xc1e9abe0
26: abort 0xc1e9f1e0
25: ZN9__gnu_cxx27__verbose_terminate_handlerEv 0x6fc5f170
24: ZN10__cxxabiv111__terminateEPFvvE 0x6fc581b0
23: ZSt9terminatev 0x6fd302b0
22: _cxa_throw 0x6fd39080
21: ZN7MidiApi5errorEN11RtMidiError4TypeENSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE 0x733d52
20: ZN11MidiInWinMM8openPortEjRKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE 0x7366e2
19: ZN4rack12RtMidiDriver14subscribeInputEiPNS_4midi5InputE 0x74b050
18: ZN4rack4midi5Input11setDeviceIdEi 0x48080c
17: ZN11MIDIdisplay4drawERKN4rack6widget6Widget8DrawArgsE 0x14bc2d3a
16: ZN4rack6widget6Widget4drawERKNS1_8DrawArgsE 0x4a776c
15: ZN4rack6widget6Widget4drawERKNS1_8DrawArgsE 0x4a776c
14: ZN4rack3app12ModuleWidget4drawERKNS_6widget6Widget8DrawArgsE 0x492bba
13: ZN4rack6widget6Widget4drawERKNS1_8DrawArgsE 0x4a776c
12: ZN4rack6widget6Widget4drawERKNS1_8DrawArgsE 0x4a776c
11: ZN4rack6widget6Widget4drawERKNS1_8DrawArgsE 0x4a776c
10: ZN4rack6widget10ZoomWidget4drawERKNS0_6Widget8DrawArgsE 0x4a83e2
9: ZN4rack6widget6Widget4drawERKNS1_8DrawArgsE 0x4a776c
8: ZN4rack6widget6Widget4drawERKNS1_8DrawArgsE 0x4a776c
7: ZN4rack2ui12ScrollWidget4drawERKNS_6widget6Widget8DrawArgsE 0x4a3fd4
6: ZN4rack6widget6Widget4drawERKNS1_8DrawArgsE 0x4a776c
5: ZN4rack6Window3runEv 0x4594ea
4: main 0x781840
3: main 0x781840
2: main 0x781840
1: BaseThreadInitThunk 0xc2667020
0: RtlUserThreadStart 0xc3722630

IMO the best is to submit an issue in the issue tracker: Issues · VCVRack/Rack · GitHub

Surround code/terminal output blocks with ``` on its own line. I’ve edited your post for you.

2 Likes