Anybody successful with MPE and Sensel Morph within Bitwig?

I am trying to MPE from my Sensel Morph to work with VCV from within Bitwig. Considering CLAP support, this should be a good match(?)

I have tried the stock MIDI->VCV module, Midi Poly&MPE (in several modes), but no luck. There is note on events, but no pitch or individual aftertouch. In standalone mode I get the Midi Poly&MPE to work.

MPE with other synths, like Surge XT (CLAP) and Equator2 (VST3) works fine.

This is what the MIDI data looks like according to midimonitor VST added in the bitwig channel:

E1 53 39 Ch.2 Pitch Wheel: 7379 (-813) D1 3B Ch.2 Channel Pressure: 59 E2 4F 3A Ch.3 Pitch Wheel: 7503 (-689) D2 3B Ch.3 Channel Pressure: 59 E1 4E 39 Ch.2 Pitch Wheel: 7374 (-818) B1 4A 18 Ch.2 CC #74 (Sound Brightness), Value: 24 D1 39 Ch.2 Channel Pressure: 57 E2 51 3A Ch.3 Pitch Wheel: 7505 (-687) B2 4A 11 Ch.3 CC #74 (Sound Brightness), Value: 17

I recommend my MPE module:

Thank you for the suggestion. I gave it a try, but similar results. I receive notes, but no articulations. I wonder if it is something that Bitwig is doing to the midi stream?

Have you enabled MPE for the plugin in Bitwig?



Input settings:


Patch (with some ‘stupid’ connections on X Y Z just to be able to eyeball any changes)

There is no response to pitch change, aftertouch or timbre. Gate and initial pitch works.

First question: Does it work in Rack standalone?

  • If yes, we have to search for the error at Bitwig.
  • If no, we have to search for the error at VCV Rack.

My setup is:

  • LinnStrument
  • Windows 10
  • VCV Rack Version 2.1.2 - no CLAP plugin in this version
  • Bitwig Version 4.4.3

What’s your setup?

for signal analysis I would suggest the Scope module:

THe difference between Bitwig’s MPE button or off is only on the X and Y axis. The Z axis should always give response.

My module reacts on Pitch Bend for the X axis, CC1 and CC74 for the Y axis and on Poly Aftertouch and Channel Aftertouch for the Z axis.

My setup is

  • Sensel morph
  • Windows 11
  • VCV Rack Pro Version 2.2.1
  • Bitwig Version 4.4.6

It works in Rack standalone, so I don’t really think it is a problem with the MPE module, but rather something in the interface between VCV and Bitwig.

I tried to downgrade VCV Rack to your version, but that didn’t go well. Bitwig 4.4.3 was no problem, and it behaves differently. I get pitch changes on the first channel only, and for modulation the data from the two keys I press on the sensel gets mixed into one output from the VCV module.

So are you still on VCV Rack Version 2.2.1?

Yes, somehow Bitwig crashed when trying to load plugins with a 2.1.2 installed, reverted to 2.2.1

What kind of plugins are you talking about? VST plugins? VCV Rack plugins?

The VCV Rack VST plugin failed to load in Bitwig after installing 2.1.2. Hopefully I will be able to look more into this later this week. (and maybe ask for support from Bitwig)

I recommend removing the file VCV Rack 2 FX.dll and the file VCV Rack 2.dll from your VST folder manually and the install VCV Rack Version 2.1.2 again.

1 Like

Today I updated Bitwig and I can tell that Bitwig Version 4.4.6 works fine with the VCV Rack VST Version 2.1.2.

1 Like

Same here. Bitwig 4.4.6 and version 2.1.2 Rack Pro running as VST2 and your MPE input module seems to work well. Looks like something is broken in the later VCV Rack version.

(And I also had to delete the VST3 VCVRack folder when downgrading.)

Thanks for your help, @Ahornberg .

1 Like