Any way to disable mouse cursor bloom/light effect?

Is there a way to disable this feature? I looked into settings file but didnt find anything. I am not really fond of it.

1 Like

If you can compile Rack on you own, you can disable the mouse cursor bloom/light effect.

In file RackWidget.cpp search for //Draw mouse spotlight and comment out the code below.

Thanks for the reply. Unfortunately I don’t know how to do that. I made a request to the support maybe it will be added to the view tab. It’s not that big of a deal honestly :wink:


Where can I find the file? I would like to try.

follow the instructions on VCV Manual - Building to download the Rack source and all dependencies, then compile the whole thing and check if it works, then search for the file you wish to change (mostly in a subdirectory of Rack/src) and apply your changes.

1 Like

Also, be aware, that if you’re on windows, you need special make dep to get ASIO if you build Rack yourself

RTAUDIO_ASIO=1 make dep

1 Like

@Ahornberg @Jens.Peter.Nielsen

I was joking. :exploding_head: I thought it was something simpler like changing the settings.json

If I try, I may be able to not get lost in code, but I prefer to use time differently these days.

it eventually will be… i raised a feature request to have a control (slider) added to the view menu to adjust brightness from off to full spotlight that was accepted


sorry, I took you seriously :coffee:

Excellent! I was going to send this suggestion on and am glad you already did it. I find the light bloom quite annoying when I want to record a patch (with video of course)


I was serious. Before I realized how complicated it was. Here in Italy when you want to do something and then you realize that maybe you are not capable, it is customary to say “I was joking” :slightly_smiling_face:


Setting the bloom to0 turns it off.

It controls the bloom from lights, but not the mouse spotlight, which I think is what the OP is asking about.


I commented those lines out, and the “room brighness” in the menu only controlled the cable brightness. The room had constant high brightness.

changing float brightness = 0.2f; to float brightness = 0.f; worked - no more light around the mouse pointer.

1 Like