Announcement: VCO-101 almost ready for release


(Highcarbschwabe) #62

VCO-3340 update: Source code is published, plugin details are submitted. Would love to be able to release today so that people can have fun over the weekend :slight_smile:


(Phil Golden) #63

Builds fine on windows!


(Highcarbschwabe) #64

Nice! So Linux and Windows are ok :slight_smile: Hopefully the Mac likes it, too!


(Alfonso Santimone) #65

BlockquoteVCO-3340 update: Source code is published, plugin details are submitted. Would love to be able to release today so that people can have fun over the weekend :slight_smile:

Great! where’s the source code? thanks


(Highcarbschwabe) #66

Here you go https://github.com/LabSevenDevVCVRack/LabSeven_VCVRack_modules.git . Have fun!


(Alfonso Santimone) #67

Great stuff really! thanks


(Highcarbschwabe) #68

You’re welcome!


(RidArt) #69

Are there any Mac Binaries or is it just source code at the moment?
Please, thank you.


(Highcarbschwabe) #70

I have published the source code so far, so currently you need to build the plugin yourself (see e.g. https://vcvrack.com/manual/Building.html). I hope it will be integrated into the plugin manager soon so that it is super convenient to install.


(Jonathan Moore1) #71

Congrats. Can’t wait to take it for a spin after the weekend.


(Marc Boulé) #72

I’m having a strange problem with the outputs, don’t know if I’m doing something wrong or not. Just cloned and built from source.

$ make -j10
g++  -Wsuggest-override -std=c++11  -DSLUG=LabSeven -fPIC -I../../include -I../../dep/include -DVERSION=0.6.1 -MMD -MP -g -O3 -march=nocona -ffast-math -fno-finite-math-only -Wall -Wextra -Wno-unused-parameter -DARCH_WIN -D_USE_MATH_DEFINES -c -o build/src/LabSeven.cpp.o src/LabSeven.cpp
g++  -Wsuggest-override -std=c++11  -DSLUG=LabSeven -fPIC -I../../include -I../../dep/include -DVERSION=0.6.1 -MMD -MP -g -O3 -march=nocona -ffast-math -fno-finite-math-only -Wall -Wextra -Wno-unused-parameter -DARCH_WIN -D_USE_MATH_DEFINES -c -o build/src/LS3340VCO.cpp.o src/LS3340VCO.cpp
In file included from src/LS3340VCO.cpp:2:0:
src/LabSeven_3340_VCO.h:7:0: warning: "_USE_MATH_DEFINES" redefined
 #define _USE_MATH_DEFINES

<command-line>:0:0: note: this is the location of the previous definition
g++ -o plugin.dll build/src/LabSeven.cpp.o build/src/LS3340VCO.cpp.o  -shared -L../.. -lRack

(Highcarbschwabe) #73

It should look like this:

grafik

I can not reproduce the issue at the moment but if something is wrong with the code I’ll find it and fix it.


(Highcarbschwabe) #74

I just had the same issue on another PC (a rather old one with a cheap graphics card + Ubuntu). Strange values + audio I/O not working properly (lots of stuttering/clicks despite maximum buffer size) + GUI had low frame rate and arbitrary frame timing. When the stuttering was gone and the GUI frame rate was normal after a while, the VCO-3340 worked as expected. The same stuttering+no sound thing occurred when loading a patch without the VCO-3340, too.

First-glance suspicions:

  • There might be something going wrong with the initialization. In particular, the VCO-3340 is an unusually large module (>4MB) because it contains a rather long noise sample. Then again, problems at VCV Rack startup also occurred without the VCO-3340.

  • Maybe this also depends on the OS and the hardware. As soon as possible, I will build and test the plugin on my studio computer which is newer and more powerful + uses an RME Fireface UFX which should be good enough to qualify as a “proper” audio interface.

P.S.: I have also experienced strange GUI rendering errors at startup. Backgrounds of modules were vertically squeezed and sometimes controls are strangely deformed. This concerns all modules when loading a patch or when starting a new one. But it only happens sometimes. After 2-3 restarts of VCV Rack, everything is fine. Here is a demonstration using some arbitrary modules


(Fractalgee) #75

never seen that happen, you sure graphics card is not to blame?


(Highcarbschwabe) #76

I guess it is. I am using a cheap one.


(David Rodriguez) #77

it happen to me allways when I open a new file or load one, is a issue about the OpenGL , Linux and rack,As far as I know, it has not been solved, I have a expensive graphic card.

just restart the rack :wink: