An issue with sending gate/clock to external device via ES-9

Hi everyone! Finally just got an ES-9. I want to send a gate/clock from the VCV clock to an external device to sync it with the VCV clock. As I understand, a gate signal is a pulse that is 0-10 volts, at least in VCV, based in the Scope. When I send gate from VCV to the device, ES-9 output shows red color (positive voltage) and blue color (negative voltage???). The question is, why does it send negative voltage? I also inserted the clock from the ES-9 back into the input and got weird visualization on the Scope. I guess it might be due to some misconfiguration.

I saw that Omri was able to do this in this video, but it seems that he doesn’t have this problem:

Looks like you’re sending/receiving through ports with DC blocking turned on. The ports on the ES-9 that you use for CV/gates/triggers/slow-LFO’s needs to have DC blocking turned off and the ones used for audio turned on. I can see on the config you turned it off for most ports but maybe you didn’t save that configuration back to the ES-9 in the way you thought you did. Remember - the ES-9 has two configurations, hosted and standalone, that is determined by it’s USB cable being connected to a powered on computer when/before it’s powered on (hosted) or not (standalone). So if you’re using it in hosted mode (with Rack) you need to make sure that it’s actually in hosted mode, that you load the hosted configuration and that you save the hosted configuration.

Hi, thanks for the response! I guess I tried all the combinations with the ES-9 config, but it is still not working. It’s been 3 days… I need someone with the same working set up so they can share their config. Maybe there are some additional configurations in VCV.

dc blocking filters on the ES-9 (which you control on the config tool) are for analogue inputs on the interface, it shouldn’t matter…

you can try changing this flag on the audio-16 module

please note that the input #1 on the ES-9 is controlled by the output #9 on the audio-16 module

hope it helps somehow…:broccoli: A

Hi @ale47p thank you for the replay! So yes, I just tried it and now it seems that the output from the ES-9 is blinking red color only, but the audio-16 from the VCV has red color now, which probably means that there’s something wrong. PS: I didn’t notice this red l color in AUDIO-16 in his video.

DC-blocking very much matters for CV and for this use case, it needs to be off. And yeah, I completely forgot that the Rack audio modules have the DC blocker now as well, and that needs to be off as well for CV.

Hmm… I don’t even know what red color means on the audio module. Has your problem been solved?

The red LED indicates clipping

1 Like

he uses outputs of the es-9, and es-9’s dc filters are on the analog inputs, so I still think that it does not matter…it matters only if he tries to track the incoming signal back again

maybe I’m wrong, but I would like to undestand why! :wink:

So I’m just testing this and there seems to be an issue with uni-polar signals. I send a clock from Clocked, which is uni polar, and I get weird results. I then sent a pulse wave from an LFO, which is bi polar, and everything was fine.

Uni polar:

Bi polar:

the same with a sine LFO that is uni polar:

I just tested it with Bitwig and it works as expected so maybe it’s a VCV thing. I will have to test it with the Mordax Data to see what it looks like although I never had issues but we’ll see. I will report back

1 Like

Ok, I tested with the Mordax Data and uni polar signals coming out of VCV 2 are weird. I tested it with Bitwig and the Data and it works perfectly. And, I tested it with VCV 1 (which I use in the video) and it also works perfectly so there’s something going on in VCV 2 with the Audio modules…


good research! Send that to support please, should be fixable if it was working fine in 1.x

Not seeing any problems on the ES-3 mk3

Here, a 0-10V 1Hz sine from VCV to ES-3 jack 1.

Measured using Analog Devices ADALM2000

ES9 user here with rack2 pro. Tried sending a square lfo out from es9 and back in and all seems fine. Never had issues with that. Are you running latest drivers and firmware for the es9?

1 Like

Hi @M, thanks for the replay! That’s weird, bc Omri was able to replicate the issue. Just to clarify, you can send the clock/gate from the VCV to the ES-9, and it works fine? Can I ask you to provide a screenshot of your config for the ES-9 as well as a screenshot from the VCV (especially what AUDIO-16 looks like)? Thanks!

here ya go. ES9 driver version is 5.30 and i have latest fw installed. rack 2.1.0

@MrMoustache thanks for your effort! I’m going to replicate it on my side and share the results. Just to clarify, DC-filtering is off in AUDIO-16?

Dc block is off in vcv audio module. Only place where i have dc block on is in the es9 for my 8 first inputs as you can see in the config tool screenshot. I bought the es9 shortly after it came out and never had any issues like that, really weird… I don’t think it matters here but i’m running rack in reaper just in case.

It seems that I’m doing something wrong, but I don’t understand what exactly. First thing, when I send the clock to AUDIO-16 output #4, nothing is happening in ES-9 (it doesn’t blink and nothing happens).

When I send clock to AUDIO-16 output #9, output #1 is blinking (I assume due to the default config of ES-9). Anyways, If I send the clock to AUDIO-16 output #9 (ES-9 output #1) and then back to ES-9 input #10 (VCV input #10) this is the result:

BTW, I’m using VCV Pro 2.0.6, couldn’t find 2.1.0, ES-9 5.30, 1.2.2

Are you using the vst or standalone? Maybe test this in a daw see if you get the same results, have you tried sending audio in and out? Does stuff sound ok?

Standalone. But should it be an issue? and don’t you have some custom config? Im asking because I tried to replicate you example and did not work. See screenshots above.