Always error 0xc000001d :-(

Hello ! I receive this error when I start Rack 2. It start never more. I’m under Windows 7, 64 bits, … I stop my Avast, no change. An idea to resolve the situation ? Thank a lot ! Didier.

What does the log say?

Nothing special. The setup do without error, but when I start the VCV software, I see directly the error 0X… message.

I would probably be a good idea to run System File Checker on your PC

Start → Run → type cmd and press Enter.

Type sfc /scannow and press Enter.

The log might still be useful if you post it here.

Hi bp.dtmr & TroubledMind, thx for your answer. The result of the scan is a file of 1,289 KB, too big to transfer here, I’ve tried. New user (me :face_with_spiral_eyes: ) can not upload attachments.

0xc000001d is an illegal instruction. You’d get that error in a couple of cases:

  1. Your CPU doesn’t meet the minimum requirements
  2. You’ve added a plugin that is corrupt.
  3. Some other machine-specific issue – display drivers? audio drivers?

Listing exactly what hardware/OS version you’re running on would be helpful.

You can add it to pastebin or some other paste site.

So, the requirements are and I have … :

  • Windows 7–11, macOS 10.9–12.0, or Linux (such as Ubuntu 16.04+) - ** >> Windows 7 SP1** *** CPU**: Intel/AMD 64-bit processor supporting SSE4.2 (2011 or later) - ** >> : AMD A6-3670 with Radeon HD Graphics**
  • Graphics: Dedicated Nvidia/AMD graphics card from 2013 or later with recent driver update
  • Integrated (non-dedicated) graphics such as Intel HD are not recommended and may cause significantly increased CPU usage. ** >> : AMD Radeon HD 6530D**
  • Memory: 1 GB : ** >> : 7.5GB**
  • Disk space: 1 GB ** >> Free on my HDD : 178 GB**

CPU does not meet minimum requirements (SSE4a is not SSE 4.2) Wikipedia

You may be able to “fake it”, using the Intel Software Development Emulator - I have not tried.

So just googling the error code led me to a correct guess.

The only other time I’ve seen “illegal instruction” errors are when there’s either bad memory chips corrupting code segments, or a program scribbling in it’s own code. Given modern CPU architecture it’s actually really hard to corrupt code.

But it does remind me of a ‘grandpa hacker’ story: We were having issues with an embedded Z80 computer my company developed, so was spending a lot of time with an ICE (in circuit emulator). The Z80 has data fetch, data write, and opcode fetch cycles. The fetch & write operations toggle a pin on the Z80 which tells the memory chip whether to write what’s on the data bus or read it.

Long story short, there was a circuit board design defect, and the verkakte machine was pulling the write pin low during an opcode fetch, meaning an impossible “opcode write” cycle. So the program was occasionally scribbling on its own instructions as it executed them. We almost had OPCODE WRITE T Shirts made, but it was too nerdy even for us.

Thank a lot. How to see the version SSExxx of a CPU ? I begin to read informations about this subject.

the Wikipedia page I linked before has the info: