Ableton to vcv clock problem: internal or via midihub

Hi guys,

I’m noticing some strange clock behaviour when running VCV inside Ableton.

Running the latest versions of both Ableton and VCV.

Below you can see two instances of VCV.

1: Clocked gets it’s clock from the clock output. Calculator shows bpm from clk/n output set to quarter notes.

2/ VCV gets the same clock from Ableton but sent to my Midihub over USB and back. Midi/CV is set to midihub USB input. Same patch as the first instance, but this time the tempo is correct.

Don’t know what’s going on, but it’s strange… Any of you experiencing the same behaviour?

I’m guessing it has something to do with sample rates, since

120~\text{BPM} \cdot \frac{44.1~\text{kHz}}{48~\text{kHz}} = 110.25~\text{BPM}

Is there any way in VCV to know what the internal SR is, and what the interface(s) are running at?

I don’t think the Rack API offers a way to probe the SR of the audio/recorder master, at least I don’t know of any method to do this. The internal (engine) SR is in the args of the process() call or via getSampleRate().

Perhaps the problem in @geusens.dries 's case could be that when there is no audio module present in the patch, Rack is probably using a default fallback rate that is different than the DAW’s sample rate. Even if we are just using MIDI in the patch, I think it’s important to add an audio module anyways, so that the sample rate can be set correctly in Rack. This doesn’t explain why the patch works in the second case reported above, but I would explore more along these lines to help solve the problem and get robust alignment of sample rates across DAW and Rack.

1 Like

Samplerate in Logic, VCV are set to 48 kHz, but that equation could be the answer. So VCV is running in 44.1 if no audio module is present? I’ll have a look. Thanks for your help!

So: @marc_boule was on the money! This was a samplerate issue. I think I’ve made a stupid user mistake and was running Ableton in 44.1, VCV in 48 kHz. I’m not sure if you need the audio module: samplerate can be set in the engine menu.

Works perfect now, both running in 48kHz.


Excellent, good to hear it’s resolved! :slight_smile:

I don’t think I’d call this “stupid”. Normal VST run at the host’s sample rate and “everything just works”. I get that to support very advanced workflows with direct access to multiple audio devices VCV needs this complicated ability to run everything at different rates, but it sure would be nice if most users had an easier time.

Would it be possible to add some indicator to the UI so at least ppl would know this is happening? Or some other way to make the “normal” case more intuitive?

1 Like

I was calling myself stupid in this case, because normally I’m well aware of samplerate settings etc. :wink:

Yes, I know that. I was referring to you, too, as not stupid. I was saying gettting the SR correct in VCV is difficult, which I still believe.

1 Like