Ableton AU plugin resizing bugged (plus crashing and Host issues)

Hey folks,

Just bought VCV Rack Pro, mainly for use in Live 11, running Monterey on an M1 MacBook Pro. I’m running Ableton in native ARM mode, with the Audio Unit version of VCV using the new sandbox translation layer setup - I’m not interested in running the whole of Ableton in Rosetta. I’m aware that VCV isn’t properly optimised for ARM yet, but I’m surprised at how many problems I’ve been experiencing in such a short time - I would have thought that using it as an Audio Unit would be straightforward and painless.

One major issue is that resizing the AU plugin window is severely bugged. It keeps glitching out and resizing to a massive vertical size, with the bottom part of the plugin inaccessible, way down below the visible area of the screen. It’s impossible to access the handle in the lower right to drag it back to a sensible size. Whenever resizing, it also seems to simultaneously activate the scroll bars and go flying off to the right or the bottom. There seems to be zero way to remedy the resizing issue once it has happened within a Live set, short of deleting the plugin and starting again, which creates major issues with automation, adds the hassle of saving/loading and setting everything up again, etc. This is using Ableton and the MacBook’s default GUI scaling. (If there were resizing handles on the top and sides, then I could probably work around this.)

Not a great experience so far. Also, Host seems close to unusable within the DAW Audio Unit plugin, won’t load most plugins I tried, and is glitchy in standalone VCV when running the first synths I tried with it (bx_oberhausen, V Collection). I’ve had maybe fifteen crashes/irreversible issues within an hour or two, so I’m trying to get a sense of how likely it is for all this stuff to be fixed, and on what kind of timeline.

Any help appreciated.

You should definately write to about this, with some good screenshots. But yeah, I seem to have read some comments in here about the AU not being fully baked yet, whereas the VST(2,3) works well now.

1 Like

Thanks Lars, I have contacted them.

1 Like