Abelton VCV rack and midi controllers

Hello am new to this and sorry if this is an obvious one. Using VCV RACK 2 pro as a VST in Abelton Live Lite. Sending midi from abelton to VCV rack via the midi > cV module. Then back in to abelton ready for recording audio.

I want to also connect my Novation Launch Controller to VCV for midi mapping at the same time but when you open a new midi to cv modlue its locked to DAW and can’t see the midi controller or midi keyboard as it can in standalone. If anyone has work around I would be grateful. All the best

What version are you running?

This was an issue in 2.2.0 which should have been fixed in 2.2.1

Did you test ?
It still doesn’t work for me in Rack Pro 2.2.1 VST3 on Windows 11 + A live suite 11.2.6

I have emailed support about my findings.

I hadn’t tried it - just saw that Core Midi was now available when it wasn’t in 2.2.0.

But you’re right - still not working on Mac either sigh…

Have you reported it to VCV Jens?

Yessir, reported.

OP asked for a workaround.

perhaps use OSC for control instead of MIDI, I don’t know of any easy-to-use launcpad-midi to OSC converters. Perhaps you have a tablet you can use as a OSC controller instead - or you can just run it on another monitor. If you want to give it a go - here are some leads to get you started:

hexler touchosc
vcv plugin: cvOSCcv
vcv plugin: OSCelot

1 Like

thanks for your reply will look into this thanks

thanks for the reply I’m on 2.1.2. Can try and an upgrade to 2.2.1 and see if that makes a difference!

Core MIDI is working for me in 2.2.1 on my M2 Mac. I’m using the AU Rack pro plugin.

If you have an external keyboard would you mind trying the Midi > CV module with Core Midi to send v/oct and gate signals please? just connect them up to a scope to see if you are receiving signals.

I just tried my Keystep 37 and it worked fine.

1 Like

Interesting thanks - so the AU is working but the VSTs are not.

So I loaded Ableton in Rosetta mode to test this out. The Keystep worked fine with the AU. When I used VST3, I was able to select Core MIDI and the Keystep – I wasn’t restricted to DAW like I had been before 2.2.1. But the VST still didn’t work because there was no gate signal coming from the MIDI-CV module, which could be a different bug entirely.

That’s exactly the bug Jens and I were talking about.

So Core Midi wasn’t available at all in 2.2.0, and now it is available in 2.2.1, but the VST 2/3 are still broken because there’s no gate from Midi CV.

1 Like

There’s no gate from MIDI-CV in the VST3, but there is also no V/Oct. No MIDI information at all.

Again, seems to work fine with the AU. I did these tests using Rosetta – but is it possible this be an ARM issue, since the AU is natively complied for Apple Silicon, but the VSTs are not? Are non-ARM Mac users experiencing the same issue?

Yep I’m getting it on Intel.

thanks so much everyone for your help - just upgraded to latest VCV and will have a play around- using the VST can now select core midi but as soon as activated is disconnects the gate fro my keyboard. Will report back ASAP I have a cnahce to look at in detail. Best

Im into Modular since yesterday and was stalking arround the web for a solution to my problem

when the vst is in fokus i got no keyboard signal to the midi input which makes tweaking knobs frustrating but with my usb keyboard it works fine

i feel like it is bcuz the hotkeys from vcv and ableton are somehow in conflict

i also experience sometimes that klicking the track timeline in live 11 sends some virtual signal to vcv and gets stuck so that a quieter tone is playing without stop so i have to initalize the midi module

i hope my clues are somewhat helpful bcuz im a f*ckin newb to this