ZZC Clock Module Sync issue

Hey its me again,. having sync problems haha… so i cannot sync this module to an external clock… the closest i got was still .2% off of the correct BPM. I am in 24ppq on both modules… with the Clocked module i get no results whatso ever… help me

clocking it with phase:

clocking it with external phase via Bitwig is TOTAlly off: BPm should be 140

I think I’ve had issues with this clock as well when I exported a track to reaper, the result was certainly not in sync with what reaper thought the tempo was.

The mode buttons on Clocked/Clkd are used to determine the mode of the BMP Input at the top. When in CV mode, the BPM input accepts a CV level to set the BPM of the clock according to the Rack standard for LFOs and clock generators (i.e. 0V = 120 BPM, 1V = 240 BPM etc)

https://vcvrack.com/manual/VoltageStandards#pitch-and-frequencies

When in Px mode, BPM input is interpreted as a clock signal which Clocked/Clkd will sync itself to, and this clock signal is expected to be faster than the desired BPM by x times.

Here’s a small test setup to show both type of usage of the BPM input.

The clock on the left is in CV mode, and it’s receiving 1V on its BPM input, hence 240 BPM. The clock on the right is in P24 mode and is synching itself to the x24 output from the left clock. Normally the DAW or external clock source replaces the left-most Clock in this example, and in the DAW if we set it to 24ppqn, then the right-most clock should sync in exactly the same way. Hope this helps.

2 Likes

Hi, when i connect it like this , the ZZC clock locks perfectly to Clocked. Not sure if this is what you are after?

And the problems in your original picture are two-fold:

  1. the ZZC module accepts pulses in it’s external clock inputs, and in the left and right instances of ZZC clock you are sending BPM voltage levels since that is what Clocked gives on its BPM output (0V = 120 BPM, 1V = 240 BPM, etc.).
  2. for the middle ZZC clock, you need to set the clock ratio in Clocked, for the clock output you are using, to match the ppqn setting in the ZZC clock.
1 Like

Great! Suppper helpful Marc! Any idea’s why the phase isn’t syncing? Especially from Bitwig out? Can you please make a Phase/Clock that I can sync with Bitwig Phase and then my life is complete? :slight_smile:

what the heck? mine is not in SYNC at all…

Most likely you have the PPQN in ZZC set to anything other then 1?

tru… yet still its not exact… what the…

Is the VCV Rack audio engine set to the same rate as your audio interface?

ie: 44 & 44 or 48 & 48 etc.

For example when Racks engine is set to 44khz and the audio interface to 48khz , i will get the same result as shown in your screenshot:

If this is the case in your setup, it best to keep the sample rates the same. Hope this helps!

thx so much for that… however they seem to be both at 44 RME baby face pro

when i change to 48 it Fixes the problem… is it possible this module must run at 48?

1 Like

Can you set Rack to 48 and RME to 48 and try again?

This here please:

rack engine

Just posting this picture to be sure we are talking about the same thing.

Ah you already answered, very good!

Well i have had some things like this in the past as well when syncing with other applications.

It is best to use 48Khz, somehow the pulse from Clocked works better then. (both when sending or receiving).

2 Likes

spoke too soon… still having issues… yes we are on the same page both set now at 48k… it is now flikering between the BPM by 1 BPM

What block size are you using RME at?

flikers from 140 to 141