VCV Rack and Ableton - two problematic issues.

I’m running into two problems with VCV rack and Ableton, one I have solved, the other not so much. The first one is when I open Ableton with an instance of VCV Rack and then close Ableton, I can no longer open the VCV Rack as a stand alone as I get an error message saying I cannot run VCV Rack with another instance of it already running. I need to open task manager and look at the details to see that VCV Rack is still indeed running in the background, so it has to be ended to get it to start again in stand alone.

My other issue is VCV Rack does not update the plug-in. When I get updates, I have to update it as a stand alone, and then again when I open Ableton. A little frustrating but that’s not the biggest issue. I have updated the stand alone no problem to VCV Rack 2.0.4, but the instance in Ableton is still 2.0.3. Now 2.0.3 was itself an update and when it came out, I made sure to put the .dll files where Ableton would find it and it indeed did so. When 2.0.4 came out, I don’t know where the .dll files were saved to. VCV Rack is pinned to my Task Bar and when I hover over it, it calls it VCV Rack Free 2.0.4, not VCV Rack Pro, like it did before the update. Is 2.0.4 not a “Pro” version with .dll files yet?

first I would try to download the 2.0.4 version of Rack here: VCV Rack 2 - Virtual Eurorack Studio
and install it again
you should choose where to install the standalone and the vst of Rack

please try this and report back then


That solved both issues Stephan. TYVM.

1 Like