VCV plugins crashes using the Browser

Hi, i had since the beginning a lot of crashes using VCV Rack 2 free, in standalone, only using the browser. I had to uninstall different plugins, systematically causing a crash when i try to reach them in the browser (for example: all the BogAudio plugins)

It was not a big issue, just had to avoid certain plugins…

BUT bigger problem problem now : since the last update, the “native” VCV plugins themselves are now causing crashes and are unreachable in the browser !!! Anyone having the same issues ?

(Apart of the browser, everything seems to work fine… i’m using a relatively old macbook pro with osx 10.11.6 El Capitan)

dont know what to do bout the vcv modules, but ive had crashes from the browser aswell. and an easy way to find the problem, without uninstalling things one by one, is to sort by brand and scroll through em all to see when it crashes

The crash log will often tell you exactly what crashed. In general, browser crashing is not common.

Browser crashing is almost always because a plugin can’t handle a NULL module pointer in the code that draws the panel. Because that’s how the browser works: It asks ModuleWidgets to draw - just as they do in your patch - but there’s no Module pointer (i.e. the sound generation part) available.

This has been the case for a long time but it’s a common rookie mistake for plugin developers.

1 Like

Yes. But I’ll bet you $$$ that neither VCV nor Bogaudio is doing this. But if they are then the crash log will show who is doing it. This problem sounds different to me???

1 Like

For what it’s worth, in my Rack 2.0.5, on macOS 10.12, with all plugins updated, browsing the brand VCV in the browser does not cause any crashes. So whatever your problem is it doesn’t sound like the usual.

You have not by chance installed any “security” or “anti-virus” software on your Mac, have you?

I can confirm this browser crash on El Capitan. Which I’ve mentioned in a different thread a while back. The recent Fundamental module update has triggered this crash more recently, but there a quite a few other modules from other packages that cause this browser crash on this particular system. My other systems running more recent Mac OS seem fine though. I’ve been meaning to report this.

Hi, thanks for all the replies !!

So it looks like the crashing browser problem is known on El Capitan.

I just updated to VCV Rack 2.0.5 but it didn’t solve the problem of VCV Fundamental crashing in browser… I hope the next Fundamental updates will solve this problem !?

Hi, don’t have any anti virus installed. But, as CircadianSound said, the browser crashing problem seems to occur on OSX El Capitan. Don’t have any idea how to solve this, just waiting for updates hopefully !! Thanks.

Hi, just found a way to solve part of the problem: I went to the Rack2 user folder and just deleted the fundamental folder, then re-open the app. VCV automatically re-installed the fundamental plugins and… it worked !!! no more browser crash using fundamentals. Tried the same for Bogaudio plugins but it didn’t worked… i will retry the process later and let you know.

1 Like

yes indeed the browser crashes, but you say you use an old mac …

How old is he? mine uses osx10.13, but apparently my processor is the concern, it no longer meets the minimum required since version 2.

Rack v2 works at 80%, some modules cause the crash directly by the installation and others each time I want to choose a module.

Hi, i don’t think the processor is a problem, the crashes occur only in the browser, apart of this VCV is working very well on my computer, i even noticed it works a lot better since version 2, less CPU charge, more stable etc… I really think it should be a problem of compatibility between VCV2 and some OSX versions, a lot of users have reported similar bugs in the forum. It’s a regular problem, i guess the developers can’t test it on all existing systems !! (mine is a 10 years old macbook, running osx 10.11.6 “El Capitan”)