VCV crashes in Library view (Win10, x64)

Hey, all! Seem my dream came true! ))) It took me some time to update eveything, but I got in. So first problem I met was constant crashes when I try to filter libraty with VCV brand filter. It seems to me that 1 module doesn not load properly. How can I find out what modules crash my VCV? May be there is some log of such events?

Thanks for advice!

Which OS?


Win10, x64! Here is the last part of log where I could see Fatal something:

[67.148 info src/window/Svg.cpp:28 loadFile] Loaded SVG C:/Users/Роман/Documents/Rack2/plugins/JW-Modules/res/TinyPJ301M_white.svg [67.406 fatal adapters/standalone.cpp:60 fatalSignalHandler] Fatal signal 11 SIG. Stack trace: 48: 0x0 47: 0x0 46: _C_specific_handler 0x7ffb1dfd7f60 45: _chkstk 0x7ffb1f331fb0 44: RtlRaiseException 0x7ffb1f2e1020 43: KiUserExceptionDispatcher 0x7ffb1f330bd0 42: ZN20LengthReadoutDisplay4drawERKN4rack6widget6Widget8DrawArgsE 0x7ffacba58820 41: ZN4rack6widget6Widget9drawChildEPS1_RKNS1_8DrawArgsEi 0x7ffacdd8bc10 40: ZN4rack6widget6Widget4drawERKNS1_8DrawArgsE 0x7ffacdd8bda0 39: ZN4rack3app12ModuleWidget4drawERKNS_6widget6Widget8DrawArgsE 0x7ffacdd4b1a0 38: ZN4rack6widget6Widget9drawChildEPS1_RKNS1_8DrawArgsEi 0x7ffacdd8bc10 37: ZN4rack6widget6Widget4dr

Does this mean that JW crashes my VCV?

Delete the JW-Modules folder and start Rack, and see what happens without updating

Still get crash eveytime I open VCV, than open library and try to filter it with VCV brand only modules. At the end of the loading filtered modules I got crash.

I’ve tried to delete fundamental, but no luck - crashes over and over again.

Does your system meet the requirements listed on the Rack 2 page?

100% met with requirements. I think problem is not in hardware. I have cyrillic username on Win10. May be there is a problem…

You could move the non-cyrillic folders and use the command line options to tell Rack where the files are

Yes, it’s been known many times to cause a problem previously.

hey, I got 0 problems with that on Rack v1. How can I fix it? I don’t see here: VCV Manual - Installing & Running any specific recommendation for this case…

It’s strange, that I could load VCV start screen with template, but only if I use the Library it starts to crash, when I use filters there…

Reported to official support about this issues. Will share the info when I get it

UPD: i’ve managed to clean modules that crashed me and see that I have troubles with paid VCV Drums and SoundStage. They do not load as should and crash my VCV.