Vcv & Beatstep

Hello,

Is there a way to use vcv rack modules with m y real modular using trigger and cv out of my Beatstep first gen ? I can’t manage getting this working. :confused:

Thanks guys.

I don’t know what his set up is or how he’s using his 1st gen Beatstp but @Olival_Clanaro mentioned having one in this post:

He may have insight into your situation.

1 Like

Hi Gregory ! So let me be sure i understood, you want to use Vcv modules (like sequencers lfos etc…) to control real modular, and you plan on using the beatstep to pass the information ?

(i’m reading the beatstep manual right now, but i think it’s possible)

Ok, so according to the manual : https://downloads.arturia.com/products/beatstep/manual/BeatStep_Manual_1_0_1_EN.pdf
Page 35

If you send midi to the beatstep, you can use the cv/gate outputs with that information.
In Vcv, you need to send information from let’s say your sequencer to the CV-Midi module.
Then, the Beatstep shoul relay the information to the CV/Gate ports, and you can use it on your real modular
You might need to configure a few things in the Arturia Midi control center, but it should work ^^
Let me know how it goes, i never did something like that :smile:

1 Like

Wooo many thanks !!!
I’m gonna try that asap. :slight_smile:

1 Like

Hello,

Got my new toy today, saw a nice video from Omri saw this as a perfect companion to VCV Rack.

I’m trying to connect VCV Rack to my Beatstep Pro over USB so I can control the clock etc from the BSP.

Can you see anything wrong with this setup:

Connect BSP to computer via USB.

In VCV, use a clock module, e.g. Impromptu Modular -> CLK Clocked

and Core -> MIDI-CV module

Set MIDI User Channel on BSP to the same as MIDI-CV in VCV, I’m using 10.

Connect MIDI-CV’s CLK1 output to CLOCKED’s BPM input.

vcv1

Midi Control Centre (Arturia)

vcv2

In MIDI-CV there are 2 options, if I choose the middle option VCV will crash.

vcv3

Turning the rate/fine knob doesn’t do anything. Sync mode on the BSP is set to “INT”.

Any ideas what I’m doing wrong?

Thanks

On Clocked, you might need to choose another mode, so this may help:

Thanks Marc, still no joy I’m afraid. I see Omri Cohen uses a audio interface to just do the clock and usb for the rest, maybe I should buy an idea interface? If so, I’m just not sure which is a good one to buy as I want to keep my setup small.

https://www.youtube.com/watch?v=H7N1Sy5gqiI&t=268s

Could I just get VCV to control the clock from Impromptu to the BSP so this controls the clock and not the unstable BSPs clock (using BSPs USB to VCV) and then just use the BSP to control VCV for the rest over USB (Midi-cc)?

Not sure about your question, but having Clocked send a clock to the BSP might be a better option. Perhaps @Omri_Cohen can give you a pointer or two, since this is over my head I’m afraid. Good luck :slight_smile:

Maybe this thread will help?

Do you still have the Arturia’s MIDI Control Center open when trying to use the Beatstep in VCV?

I had the same problem. Windows default MIDI driver only lets a piece of hardware be used by one piece of software at a time. Shutting down the Control Center and selecting the middle option (the one that crashes) should fix your issue.

I’ve not had any issues using the clock over USB, it looks funky and unstable, but produces a stable beat as far as I can hear. :slight_smile:

Can you help me find the “device settings tab”? Its realy frustrating that i not found. I feel like a noob. I searched everywhere but i cant set up the clock resolution. Here is the picture of my “arturia midi control panel”

hello I have a Minilab and the device setting tab displays only what I can manage for this device. Don’t know if it helps

1 Like

Just click that big ‘Project’ tab to access Beatstep’s CV/Gate out settings. That image in the manual is a bit misleading as it’s not specific to the software you’re using. Controlling knobs in VCV modules with Beatstep works great.

here is my project tab. i dont see the “clock settings”

What are you trying to do?

i want to sync my beatstep’s clock with vcv. Its not sending clock right now and I read that i need to set the clock resolution.

OK try this: select Arturia Beatstep as your controller in Midi-CV > add MIDI-MAP and select Beatstep again > add Impromptu CLKD > enter CTRL mode on the Beatstep > map the BPM dial in CLKD to the big level knob on the Beatstep. Good luck.