Unable to update to v2.0.1

My V2.0.0 is working fine, but it has a red dot by the Help menu, and an option to update to v2.2.1.

But when I click on the update option, VCV immediately shuts down, and nothing is updated.

I am running Win 10 Home 64 bit.

Anyone know a way forward?

I ran into this today. Open a browser (the same one Rack opens when you go to browse the library) and log into your VCV account, then open Rack and run the update.

I was logged into VCV rack from the browser. I tried shutting down V2, logging out of VCV, logging back in, and then running V2 and update - no luck :frowning:

Very odd. My library updates are working great - no delays or hiccups. Just the VCV update is failing. I’ll send an email to support

Not sure if it helps but I had the same issue and simply installed v2.0.1 from browser, kept all my settings so acted like an update.

Using the built-in update notification under help, closes the app and opens a browser with: https://api.vcvrack.com/download/RackPro?arch=win&version=2.0.1

This page gives me the following error: {“error”:“Token was not given or is invalid”}

reading above in the thread, I realized that I use Firefox/Brave/Vivaldi but am only logged in on one of the browsers. The link opens in Edge on Win10 (and Safari on Mac) because I leave them as the default browser. Logging in on Edge fixed it…


1 Like

Oh geez - I feel silly now. Yes, I also had the issue with the invalid token, but after logging into the correct browser, I didn’t realize it was downloading an installer exe. I assumed it was like the module updates. Doh

I’m all good now. Thanks.

1 Like

Don’t use those api URL’s, they’re only for use by Rack itself. Instead just get the latest release from VCV Rack 2 - Virtual Eurorack Studio