Unable to install VCV Rack 2.0.0 on Windows 10

I don’t see a full log.txt in that thread, only a partial one, so I can’t suggest anything else from that. Does your system meet the minimum requirements for Rack, listed on the web site? In particular for graphics?

System requirements is OK for me. The problem was in JackRouter ASIO! ) The problem was solved when I deleted record from the Windows registry! See details in thread please if interested, thanks!)

1 Like

Its been almost a month. Still no luck getting VCV to INSTALL on my Windows 10 machine.

Even with the new 2.0.4 installer I get the same result!

Anyone else still facing what I’m facing?

I know its a tough time to expect support on this from them and I’ve raised a support ticket on this and even with the pro support im still here typing this.

Try this:

  • Go into settings, find UAC (User Access Control) and temporarily set it to the lowest/most permissive level.
  • Download/locate the Rack installer .exe file.
  • Right-click the .exe installer file and select “Run as administrator”.

Does that improve things? Also, remove any 3rd party anti-virus programs you have, and just rely in the inbuilt Windows Defender. These things cause so much trouble and are pure trash.

1 Like

I’ve had about 4 windows systems I’ve built and maintained through my time and did the basics like you mentioned on first attempt on facing this issue.

I’ve even been in touch with the PRO support tram that you get with the paid version and their suggestions are as basic as yours and still have left me hanging.

I’m posting here to see if anyone else has had this issue and managed to fix it or have they just given up and asked for a refund.

Nothing has worked for me. Not even on the rack 2 free installer.

I had the versions before 2 working just fine on this machine.

I haven’t had any installation issues on multiple Windows machines.

Which anti-virus are you running? What are the security settings of your user account, do you have all administrator privileges?

I see you said that nothing happens after you answer the security prompt. At that time, is the installer running but not visible, or has it terminated? You should be able to check that with the details section of Task manager, or sysinternals’ Process monitor. The Windows event log should also have related diagnostic messages if it is having problems running the installation.

Are all the latest Windows updates applied? The latest NET and VC++ runtime?

And this is not a solution, but there is a ZIP version of Rack 2 Free that lets you manually install Rack. The latest is 2.0.3. The standalone Rack Free is functionally almost identical to standalone Rack Pro. The Rack VST isn’t in the free version, of course.


So you get this :


Press “YES” and nothing happens ?

I get those popups in the lower right - where other notifications are, “defender blocked vcv2.exe”. So I click on the notification and eventually get the a UI that’s lets me exclude vcv from controlled folder access. Don’t know if that’s what this issue is…


same here

btw the other Thread has this issue also

Hey,i got it running via the ZIP for a short time… but later VCV opens a invisible window then, so it ist not a solution for me,

i have the same install issues…in Win 10 Pro

@Yeager same here with 2.1.2 i log the process via procmon (win sysinternals)#

→ i can explain how to to it.<-

This is what it captured if anyone will digg deeper in this rare issue:

20:13:15,0066632	RackPro-2.1.2-win.exe	10988	Process Start		SUCCESS	Parent PID: 4400, Command line: "C:\Users\cccc\Desktop\RackPro-2.1.2-win.exe" , Current directory: C:\Users\cccc\Desktop\, Environment: 
	CommonProgramFiles=C:\Program Files\Common Files
	CommonProgramFiles(x86)=C:\Program Files (x86)\Common Files
	CommonProgramW6432=C:\Program Files\Common Files
	DokanLibrary1=C:\Program Files\Dokan\Dokan Library-1.2.0\
	DokanLibrary1_LibraryPath_x64=C:\Program Files\Dokan\Dokan Library-1.2.0\lib\
	DokanLibrary1_LibraryPath_x86=C:\Program Files\Dokan\Dokan Library-1.2.0\x86\lib\
	Path=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\WINDOWS\System32\OpenSSH\;C:\Program Files\dotnet\;C:\Users\cccc\AppData\Local\Microsoft\WindowsApps;;C:\Program Files\Imaginando\VS
	PROCESSOR_IDENTIFIER=Intel64 Family 6 Model 60 Stepping 3, GenuineIntel
	ProgramFiles=C:\Program Files
	ProgramFiles(x86)=C:\Program Files (x86)
	ProgramW6432=C:\Program Files
	PSModulePath=C:\Program Files\WindowsPowerShell\Modules;C:\WINDOWS\system32\WindowsPowerShell\v1.0\Modules
	VBOX_MSI_INSTALL_PATH=C:\Program Files\Oracle\VirtualBox\
	windir=C:\WINDOWS	Process	33	C:\Users\cccc\Desktop\RackPro-2.1.2-win.exe	00000000:000273f1	Verbindliche Beschriftung\Mittlere Verbindlichkeitsstufe
20:13:15,0066692	RackPro-2.1.2-win.exe	10988	Thread Create		SUCCESS	Thread ID: 16376	Process	34	C:\Users\cccc\Desktop\RackPro-2.1.2-win.exe	00000000:000273f1	Verbindliche Beschriftung\Mittlere Verbindlichkeitsstufe
20:13:15,0079775	RackPro-2.1.2-win.exe	10988	Load Image	C:\Users\cccc\Desktop\RackPro-2.1.2-win.exe	SUCCESS	Image Base: 0x10000, Image Size: 0x1e2000	Process	35	C:\Users\cccc\Desktop\RackPro-2.1.2-win.exe	00000000:000273f1	Verbindliche Beschriftung\Mittlere Verbindlichkeitsstufe
20:13:15,0080515	RackPro-2.1.2-win.exe	10988	Load Image	C:\Windows\System32\ntdll.dll	SUCCESS	Image Base: 0x7ff9f98f0000, Image Size: 0x1f8000	Process	36	C:\Users\cccc\Desktop\RackPro-2.1.2-win.exe	00000000:000273f1	Verbindliche Beschriftung\Mittlere Verbindlichkeitsstufe
20:13:15,0080926	RackPro-2.1.2-win.exe	10988	Thread Exit		SUCCESS	Thread ID: 16376, User Time: 0.0000000, Kernel Time: 0.0000000	Process	37	C:\Users\cccc\Desktop\RackPro-2.1.2-win.exe	00000000:000273f1	Verbindliche Beschriftung\Mittlere Verbindlichkeitsstufe
20:13:15,0083176	RackPro-2.1.2-win.exe	10988	Process Exit		SUCCESS	Exit Status: -1073740756, User Time: 0.0000000 seconds, Kernel Time: 0.0000000 seconds, Private Bytes: 2.293.760, Peak Private Bytes: 2.293.760, Working Set: 1.564.672, Peak Working Set: 1.568.768	Process	38	C:\Users\cccc\Desktop\RackPro-2.1.2-win.exe	00000000:000273f1	Verbindliche Beschriftung\Mittlere Verbindlichkeitsstufe

I dont know what this Programs do there:

  • one drive (i dont have and dont use it)
  • internet explorer (nope i only use firefox)
  • audio plugin expanse (wtf???) → Has to do with Csound Environment but why for this Process?
  • audio plugin imaginando VS (wtf???)

it make no sense to me…but it is possible that are

Where is VCV installed? In what folder? It looks like you have it on the desktop? It is common to have it in the program files folder. Have you also installed all the dll’s also on the desktop?

Maybe first try a normal install and see if you can get it running. Than move ot to the desktop if that is what you really want (Iwould create a shortcut but that is just me)

its not installed. (Thats the Thread about)

The Installer RackPro-2.1.2-win.exe is normally in my Download Folder (not on C:) The Installer is now waiting on my Desktop (until the install process will ever happen.) and i try starting the Installer from both Paths…

its not common to have the installer in the program files folder…maybe u mean it should install there…thats true then.

i have actually Rack Free 2.0.2 ZIP -unpacked on Desktop- also to try if this is working and it does work…but i can not update via the Rack Pro Standalone GUI

i try all kinds of installing. if u read above (Unable to install VCV Rack 2.0.0 on Windows 10 - #24 by PaulPiko) you know exactly what happens before…and waht always happens if i/we double click the installer.

Of course, the issue is about the installation. It was too early for me when I responded I guess and did not have my coffee (hope that is a valid excuse :-))

So, see if I can be of better help for you.

You say: i have actually Rack Free 2.0.2 ZIP -unpacked on Desktop- also to try if this is working and it does work…but i can not update via the Rack Pro Standalone GUI What do you mean by that? Rack Free and Rack pro should be installed seperately. So you have the free version running?

1 Like

i was long time not trying this and switch to Cardinal ^^,

it was running, but i thought it brokes as well, when try to upgrade in any ways…

but anyways, will give it some time and will try it later imean pay for it, because the Free Version was running.

Somethings happens…not sure what exactly…maybe its windows update or something.

dont know, if nobody can read something from my informations…iam kinda lost at it

I GOT THE SOLUTION right now !!! :face_holding_back_tears:

I found the Solution as i was trying to use PortableApps-Applications and got the same ErrorCode…huh*?


So i combine this “Code” and “PortableApps” in google that leads me to the Forum. And there was a Guy with IQ 5000.

The Solution is:

  1. Go on start and type “Security” that leads you to the Security Settings
  2. Click on App&Browser Control
  3. Click Exploit Protection Setting
  4. Change ‘Force ranomization for images (Mandatory ASLR)’ back to ‘Use default (Off)’.
  5. Reboot

I followed the instruction an i can now install Rack 2.2.1. without any issues, warnings or silence-nothing. Windows should tell me that 4 sure that THIS Setting harms the Process. Stupid Windows !!

I did not check out if VCV will run if this Security Option is activated again after the Installation of VCV.

Original-Post: error 0xc000007b after win10 update | PortableApps.com

meryy xmas - happy new year nwsm


OMG Pin this! this is the solution that worked for me after trying to get VCV installed for YEARS!

1 Like

btw, if you turn off ASLR you are turning off a security feature.

As i wrote

  • anyone should activate it after the install process, i think VCV will work

VCV should modify the install process in next update, to keep security feature when installing VCV