Ubuntu - Log in > No response from server

When I want to connect (under Ubuntu) the Rack software, the message on the software : No response from server

Yet I can connect without any problem via the Rack web interface.

I tried many things, however, disconnection of the Vpn … But it remains the same.

Thank you to indicate me a solution ?

Best regards,

I had this a while ago. I made sure I had a back up of everything then reinstalled Rack, signed in and everything was OK so my library uploaded again and I copied back all my saved patches. Not the cleverest solution but it worked for me!

Thank you !

I’ve done it before, but it doesn’t work. The situation remains the same

could be the Firewall?

try this

sudo ufw status

if the output is “Active” try

sudo ufw disable 

Then run the vcv rack

I just tried it, but even disabling ufw, it still doesn’t work.

Thank you David !

Same problem here with the Raspberry Pi 4 Docker Build from @hexdump

@s.bratel - the arm builds are debug builds and are thus not connected to the vcvrack library - all modules available as open source come precompiled with them - so for those arm builds log-in does not work by design

best wishes - hexdump

ah okay, thank you, that makes sense.

Problems :

  • Rack is not a package
  • Rack is not an AppImage
  • On the manual: the only indication to install under Linux > Unzip the zip file = haha!.. Knowing that this is an unconventional installation.
  • No answer, despite several reminders, on contact@vcvrack.com

What to do ?

it have a package , available here: https://vcvrack.com/Rack

and it is exactly the way for install in Linux, unpacking , nothing more

it is a very common way for install software , the installers simply unpack files in certain locations

to execute simple run the “Rack” file in the package

how to run? for mostly of the modern linux s double click on the file , if it not work , check for the execution permission, (if you are usng gnome, I think nautilus not allow the execution by default, then go to the nautilus preferences, then enable “allow run files as programs” or something like that )

or from a terminal with

./Rack

for the problem with the server try this, go to the Rack folder and delete the file “settings-v1.json” run the rack and logging in your account

This email address is for commercial VCV plug-in support so you are very unlikely to receive a reply to this query via this route.

It’s fine to ask here but if the community can’t help this is the route for Rack itself: Bugs and Features — VCV Rack documentation

No ! Unfortunately it is not a package. It’s just an archive.

Yes! Packages or AppImage are very easy to install on Ubuntu.

But archives (without install.sh), it’s much more risky … The proof is in the title of my initial message.

When you delete “settings-v1.json”

and then launch Rack the message is : Rack’s resource directory “./res” does not exist. Make sure Rack is correctly installed and launched.

How are you launching Rack?

The message about the resource directory most often occurs when the present working directory is not the Rack directory.

Rack is very self contained, it really doesn’t need a package, although it might be nice.

The message about the resource directory only occurs when I delete the file “settings-v1.json” as David Rodriguez suggested.

Personally my problem is not in the launching of Rack but in the impossibility (as I indicated in my initial message) of logging in (to download the plugins in the library) with the message : No response from server

Indeed it would be great if there is a package or an AppImage for Rack …