Synchronizing to Elektron Digitakt

Hello.
I wonder if anyone has successfully tried to synchronise the clock of VCV Rack with the Elektron Digitakt like Omri Cohen did that with the Arturia DrumBrute in this Youtube video: https://youtu.be/C5_yTmeb9gw
I tried it but was not able to get a stable clock. I do not know, if it is not possible, or if I just didn´t find the right settings. Maybe someone could try that out?
Thank you.

Hi Martin!
I think that the Digitakt has no analog clock input\output right? Also on the DrumBrute, when using Midi, it’s not the most stable, but from my experience, it pretty negligible. I use now the BeatStep Pro as my main clock, and again, it’s also not the most stable, but it works really well anyway. Of course, the best will be to send the actual analog clock, but if it doesn’t have one then Midi is the only way…

I think the only way is via MIDI. I use Mainstage on my Mac as Masterclock for all hardware and Rack. Maybe you could use the Digitakt as your Masterclock?

@Omri: nope, no analog clock input :slight_smile:

No, there is no analog clock. Only midi. But I get total different timings. For example Digitakt 120 BPM and VCV rack 80 BPM. I found no setting in the Midi-1 module and clocked that was nearly the same. Same is with stop and play button. I get no response in VCV rack. Synchronisation in other programmes like Bitwig works.

That’s weird… Did you check the clock resolution settings? Can you change it on the Digitakt? I think that 24ppqn works best.

Thank you Omri.
I tried several clock resolution settings, but was not able to get a equal BPM in VCV Rack and Digitakt. Unfortunatley is not possible to change it on the Digitakt. At least I did not find any settings for that in the manual.

I tired to find something on google, but couldn’t find anything… What I did find though, is that the Digitakt will continue to send a clock also when you stop it. You can “fix” this by sending the Start and Stop outputs to a unity mixer or an OR logic module, and send this to the Run input of Clocked. That way, when you hit Play or Stop, Clocked will also react. But what’s going on with the BPM? That’s really weird…

Thank you for your help and the “fix” option.
In the mean time I tried another midi sequenzer, and the same problem occures. So it seems to be not a problem with the digitakt, but with my installation of VCV Rack or my PC. I even tried out VCV Rack v1, but with the same outcome.

Oh… I wonder what it can be…

Sooo, any news on this topic here? I also wondered today how to bring my Digitakt into the equation, but… eh. I can sync the clocks kind of alright, but only with that 24ppqn setting. This however, seems to overwrite or also trigger the Clocked’s Run - it’s always on, I can’t pause it, not even with the module’s button. I guess using Midi-CV’s Start/Stop/Cont outlets and AS’s Flow or something to mute Clocked’s triggers would be an option but there surely must be something more gratifying?