Stuck at Plugin development Tutorial

Hi all,

I am currently going through the Plugin Development Tutorial and all is fine except when i am to run the “make” command after succesfully creating MyPlugin. I get this:

Makefile:23: Rack-SDK/ No such file or directory make: *** No rule to make target `Rack-SDK/’. Stop.

Inside my Rack-SDK folder I do see a file.

I am aware the tutorial mentions to run it while inside the plugin directory but is it VCV rack’s plugin directory or the one created with createplugin? I’ve tried in both scenearios with the same result

Similarly when going to the next step and creating my module while inside the MyPlugin directory i get a:

-bash: Rack-SDK/ No such file or directory

While I am not a complete beginner to programming however I am in no ways close to considering myself intermediate let alone advanced. I read somewhere that someone fixed it by reinstalling homebrew. Did that already and results are the same. Is there some very easy solution or step that I just missed? any help is greatly appreciated.

macOS 11.6 X-Code 13.1

this is most likely because you forgot this step:

export RACK_DIR=<Rack SDK folder>

I recommend putting this in your .bashrc/.bashprofile so you don’t have to do this every time you open the terminal.

1 Like

I did run that line successfuly (i hope). Just re-did the whole tutorial (that step included) and I am getting the same result

Did you literally write it like that? That would not work, you have to put in the actual location of the Rack SDK, not that placeholder text.

Oh the location… not the name of the folder by itself which is what I have been doing all this time. Just wrote in the path of my folder instead of the folder name just now and it seems to have worked.

reading your “actual location of the Rack SDK” made me realize to write in the path.

Thank you so much!