SOLVED Waves plug-ins in host-fx not working with VCV 2 Rack Pro


I’ve been using host-fx with my Waves plug-ins in VCV1. When clicking the waveshell, it opens a submenu and you see all your plug-ins.

In VCV2 Pro the submenu doesn’t work (not for vst or vst3), instead the host plugin wants to load the entire waveshell.

Any suggestions on how to fix this? Thanks for your help.


Yeah not working here either. One of the main use-cases I bought this for is to modulate RBass…

Working here in 2.0.3b for Mac in Ableton

I don’t have a Host solution for you but, maybe a potential work-around that may get you the results you need while development makes Host play nice with Waves plugins. You said it is not working in VST or VST3, so I presume you are in a DAW. Rather than using Host, you could use a multi channel audio device in the VCV VST and have your DAW break the outputs into separate channels, then run your waves plugins on the channels that need them directly from your DAW.

@mushoo Have you updated VCV Host?

From the VCV Host changelog, this fixed it for me:

Host Changelog

2.0.2 (2021-12-06)
  • Fix loading VST3 sub-plugins such as Reason Rack Plugin.

Yes: solved

1 Like