[Solved] MIDI-CAT crashes VCV R2 on initialization

As MIDI-MAP doesn’t work on V2, I compiled MIDI-CAT from https://github.com/SteveRussell33/vcvrack-packone, the module MIDI-CAT works on V2 but it seems to have a bug : if I want to reinitialize it, VCV R2 crashes (shuts down with no warning). Does anybody experiment the same issue ? I’m on UbuntuStudio 21.10.

Edit : I built the vcvrack-packone on mac and same issue (no shutdown but the famous color wheel and then “force to quit” on VCV Rack).

Same problem here on Mint 19.1

You also have MIDI-MAP not working ?


Seems to have a bug, as I edited on the first post, it also freezes VCV R2 on mac. And I don’t know how to report bugs on modules.

I’ll do it.

It trashes the patch too as rack crashes on restart.

Isn’t Ben’s original repo the one to be building from now? I believe Steve Russell’s changes have all been made in the original.

Indeed. My mistake, I raised an issue on Ben’s github - doh. Building rack from source now, next stop Ben’s stuff.

From what I saw on the two git repos, Steve’s one seems to have been updated more recently than the original one, no ?

This is now fixed so rebuild from Ben’s repo.

Is it this one ?

No - Steve’s last commit was 2 weeks ago. Ben has made 11 commits in last 3 days

Yes, you need to grab the v2-dev branch.

Thanks, that’s working now ! :smiley:

1 Like

Crash on initialise should be fixed now, you might want to mark this post as the answer:

Or edit the title of your thread, with : solved