ShapeMaster Pro VST VCV 2 Pro Bitwig

Take a look:

Can you show EQMaster also please?

Here:

Ok, and just to be absolutely sure, can you show us the version number as shown here:

As requested:

1 Like

ok, sorry for all the questions, but since we can’t reproduce the bug, we really need to look at a whole lot of things, so thanks for your patience. Can you show use two more pictures please, like these, so we can see the exact Rack version and list of plungins installed:

image

Yeah, im interested in making in work, I love this module and hope could enjoy playing with it as soon as possible)))

Screens:

Ok, now since there are many plugins installed, to be sure the bug is with MindMeld, we will need to try this please:

  1. close Rack, and go to the Rack2 folder in Documents and setup a temp folder on your desktop, like this:

  1. Drag all plugin folders except MindMeld and Fundamental over into that temp folder.

  2. Start Rack Pro again and do not do the library update. Is the problem still there?

  3. Move temp plugins back to their original location.

1 Like

I got cyrillic username on my Win10, x64. That is already caused problems with VCV Drums, I could not use them… May be there is such problem also with MM modules?

1 Like

Yes, I think that this could be it. The reason why the labels are showing on MixMaster but not our other modules is that in MixMaster we are using a Rack font, but in all others we use a font that we have in our plugin. If the Cyrillic characters in your username are posing a problem, then our font can’t be loaded and when that happens, the drawing is aborted.

If you were having problems with VCV Drums also, then I think the problem will also potentially happen with any plugin that loads local resources, so perhaps it would be best to relocate the Rack2 folder elsewhere (this requires some attention to detail so that it’s set up properly), or change your username (I don’t mean to say this in an insensitive way, as your name and Cyrillic characters are part of your culture, just as the “é” in my name is part of mine, and has sometimes caused me problems too! :slight_smile: )

6 Likes

Great catch! Looks like this might be the cause :slight_smile: :crossed_fingers:t4:

1 Like

Glad it looks like we hopefully got to the cause of this problem… but if you already had another plugin not working, and you knew the cause, it would probably have been a good idea to mention that much earlier…

1 Like

Wish I could know how to move that folder away from windows user! In VCV support prommised to fix this problem soon. Hope it will help everyone with such problems.

That’s good to know, hope it will help us also.

For relocating the folder, it’s perhaps as simple as moving the folder and then adding a flag to the command that launches Rack, as shown here regarding the -u command:

https://vcvrack.com/manual/Installing#Command-line-usage

Here’s how to modify the desktop shortcut:

Or if you launch Rack from a windows command prompt, here’s how the general syntax looks:

C:\Program Files\VCV\Rack2Pro>Rack -u C:\Rack2

1 Like

How about Documents/Rack2/ folder?

Not sure that works, since Documents\Rack2 is located in your user account, and is currently what you are using by default, but if you were to set up a C:\Documents\Rack2, then that would work I think.

Me 2, but the problem is there. not in Program Files/VCV folder. So I need solution for Documents/Rack2 folder or patch from Andrew )))

The bit you need to change is the part after the -u so the place where Rack is installed, in Program Files is probably fine. You just need to ensure that Rack is using a user directory which doesn’t have the international characters.

1 Like

Just to be extra clear, -u is the user folder, which is separate to the Rack system installation folder

https://vcvrack.com/manual/Installing#Command-line-usage

1 Like

How can I change this path for VST? This method affects only standalone folder recognition. Is there a way to thange this system path?