Reset Sequencers are one step off

Hi there! I’ve been experimenting with VCV rack a lot lately and I’ve been using many different sequencers. Here, I came across a problem that really bugged me: When I have several sequencers running and I reset them all, some of them are one step off!

I first noticed the problem with the AS SEQ-16 and to explore the issue I created a patch where I clock and reset all sequencers from the same module (AS BPM clock). For the sequencers that output a trigger signal which I often can’t see on the VCV Scope I added a trigger to gate converter (Bogaudio DGATE) to have a gate signal that I can inspect on the scope.

I tried it with

  • AS SEQ 16
  • VCV SEQ-3
  • JW-Modules Trigs
  • cf ledSeq
  • Voxglitch Digital Sequencer
  • Count Modula Basic 8 Step Sequencer
  • Lomas Gate Sequencer

On each of them I created a 4 step sequence with a gate or trig on the first beat. I compared them all against the VCV SEQ-3. Only the AS SEQ-16 and the Lomas Gate Sequencer synchronized as the SEQ-3, the other sequencers had their first beat where the SEQ-3 had its second beat.

Is that a bug? A non-standardized issue? How do I deal with that?

EDIT: I just noticed that the Voxglitch and Lomas Sequencers can switch “reset modes” between “next clock input” and “instant”, where “instant” produces the behaviour as the SEQ-3. Unfortunately, the Count Modula, JW-Modules and cf modules don’t have this option. But that means that they are probably waiting for the next clock input before they start their operation, so by feeding them an additional impulse before that would synchronize them to the others …

1 Like

Hi and welcome to the forum!

Have you read these threads?

and this:


There’s nothing wrong with any of the sequencers or the clocks.With most clocks, if you reset them whilst the output is high, it simply restarts the cycle and leaves the output high so rher is no positive edge presented to the sequencers and they then wait of the next clock cycle. Same happens with hardware sequencers. I have this module which I use to solve that issue:

Run your clocks through this and use the reset output to reset all your stuff. This module ensures there is always a positive edge presented to the sequencers when you reset regardless of where the clocks are in their cycle by by pulling all the clock outputs low for a few cycles when the reset occurs.


Thanks for the kind replies! I tried a search, but I guess I didn’t hit the right wording to lead me there, so thanks @Eurikon for the links!

I tried it with the module you created @CountModula but the issue persists. Maybe I’m doing it wrong :face_with_raised_eyebrow:

I’m going from the AS BPM clock 16th output into the clock 1 input of the Master Reset and with the Reset output into the Reset input. Then, I changed all the routings to go from the Master Reset to all the sequencers instead of directly from the AS BPM clock.

Whether I hit Reset on the AS BPM clock or the Master Reset doesn’t matter. The offset stays as stated in my OP.

@ravenfrost if you upload your patch file I’ll take a look.

In this setup only Voxglitch misses the first beat but is still in sync.

PS. When I hit Reset while the clock is running, I get all sorts of “problems”, but when I stop the clock, hit reset, start the clock, they all sync up and start on the first beat (except voxglitch).

@Yeager The sample delay method might work, I’ll try it out, thanks for the hint. Also, the “stop and reset” is a great workaround for now! I didn’t think about this, so this is really helpful.

Here I uploaded the patch for you to look into @CountModula Thanks for doing so! sequencer_offset_problem.vcv (43.8 KB)

1 Like

sequencer_offset_problem.vcv (48.4 KB)

I always use Clocked - with the following options:

  • “On Start” → Do internal reset → on / Send Reset Pulse → on
  • “On Stop” → Send Reset Pulse → on
  • “Output reset high when not running” → off

Never had any problems with sequencers out of sync and it immediately fixed your patch for me.

  • mo

Excellent, Clocked has many settings precisely for this kind of setting up, thanks for mentioning it!

1 Like

After having a play with your patch, I think it is nothing to do with the clock but but how the reset is being handled. I couldn’t load a couple of the sequencers as I don’t have all plugins installed but of the ones that did load, Seq3 and and the AS Seq 16 reset to step 1 and play step 2 on the next clock cycle whereas the JW Trigs, LedSeq and Basic Sequencer reset to no active step and play step 1 on the next clock cycle.

@CountModula Thanks for looking into this! It helps me to understand the issue better.

@mosphaere @marc_boule I set up clocked (you refer to Impromptu clocked, right?) the way you described, but it doesn’t help, the issue persists… sometimes.

I think I figured that when I send two resets between two clock pulses everything syncs up nicely, but when I drive the sequencers with 16th pulses that is not really feasible anymore.

However, while all of them run, they still end up one off more often then not.

How do I overcome the problems here? I would really like to be able to reset my sequencers and them all being in sync afterwards.

Have you tried my modification to your patch? I attached the modified file. Which sequencer is running out of sync “sometimes”?

RCM SEQ Adapter works for me.

1 Like

I was non-creative today, so I did boring stuff. Here are the first 26 Sequencers mostly from different Developers that I found in my library - running perfectly in sync with Clocked and the beforementioned settings.

There were two sequencers, that had to set a “reset option” in the menu: “Nysthi Dual Five Steps” and “Voxglitch Digital Sequencer”.

The eagle eye will spot one sequencer out of sync (first row, fourth seq), which is the “JW 1Pattern” and that is correct, because it divides the incoming clock and sends a trigger when a divider is hit. So it triggers on 8 and not on 1.

Sequencerious.vcv (301.0 KB)

In addition there is no difference if there is an additional reset between stop and restart. The only difference was, that when “Outputs resets high when not running” was on, there were a few sequencers off (mostly one step early).

  • mo

Thank you so much!!!