Remember VST window size or make it presettable

Thank you for your quick reply. Unfortunately this does not work for me.

Here’s what I tried (each time from the beginning):

  • VCV instance created, opened, window resized, save
  • VCV instance created, opened, window resized, save as “template-plugin.vcv”
  • VCV instance created, opened, window resized, overwrite template

Each time the instance opens in the original size. I also added a module as a test, which was taken over in the template.

Am I missing something?


System: MBP (M1), MacOS: Monterey, Bitwig Studio 4.1.2, VCV Rack Pro 2.0.6

Just to make sure: simply adjust the window size, then from the File menu of the plugin choose Save template?

I tried this both in Reaper and Live on Windows 10, and Reaper on Linux, and it works in each of those.

Yes almost… except that there is no “Save Template” menu item for me, only “Overwrite Template”, which is probably the same thing. I have also tried this.

Ahh okay! Sorry. Forgot I’m on 2.0.4, still (didn’t know it had changed, though :slightly_smiling_face: )

Interesting to hear from someone else on 2.0.6 - and on Mac - whether this works or not. Other than that, there’s a possibility that your specific DAW is forcing the window size for some reason?

This is a known issue on Mac, but I believe it was fixed on Windows. I have a VCV support case on it and here’s a video of how it looks on my machine, Reaper in this case but same on other DAW’s, also with a comparison to how a well-known competitor behaves in the same environment:

The issue is demonstrated in v2.0.4 but is still the same as of v2.0.6.

1 Like

No idea if Bitwig forces the window size. I’d have to check with support there, but LarsBjerregaard says that’s a known bug on Mac.

@LarsBjerregaard thanks for the video!

1 Like

It might be helpful to write to VCV support and refer to me and the video, and say “I have the same issue”.

1 Like

Yep, good to know it’s a known issue there; pretty unlikely that it’s related to a specific DAW, or something else messy like that, then :slight_smile:

@anyway did you find a workaround for this? It’s so frustrating.

Thanks for bringing this to the top again!

No, I don’t have a workaround for it unfortunately and you are right, this is very annoying. Especially since you don’t just open the window once during a work session. Every single time you have to drag the VCV window to see more than 3 modules.

This is supposed to be a known bug, it was said, but I have no idea at what state this is at the moment.

@LarsBjerregaard had gently suggested several times that it would be a big help if you would contact vcv support about this. That is where you voice will be heard most loudly by someone in a position to do something. Are you going to do that?

Yes, you are right. I wrote to support back in January and again just now, asking them to post something here from the official side.


I just want to let you know that I received a response from VCV support yesterday regarding this issue:

Thanks for the bug report, and sorry you’re experiencing this issue! Also apologies for the delay in responding. This is a known bug and we are hoping to fix it soon.

Ask my self how often all we paying customers got this with no more reaction to all our questions? Is this called support in the nower days?

Yeah, I got the same response to that issue back in 2021, December 29th. Not getting my hopes up.

I received an email from VCV today – the problem seems to be solved. For me, the window now remains the same size as I left it.

It’s a preview build:

This is really an improvement. I have already written a feedback to VCV, but also at this place: Thanks a lot to the developers!


Yup, fixed in 2.1.1, I’m happy as well and have written support to say it’s fixed.

Oh, this is good news!! :slight_smile:

1 Like

Glad this is fixed Too bad they then broke plugin updates :cry: