Rack won't see Monome Teletype

Hi all

Sorry if this is a common question but I can’t find the answer out there. I have the beta of Monome Teletype (which looks amazing) but when I put it in the VCV plugins folder and it unfurls into the folder it still doesn’t appear as a module in the rack. Have restarted etc. etc. Any ideas? Running the latest VCV 2.


Have you looked under the brand filter for monome? Just tried it on my machine and wasn’t showing at the top as I would have expected but it’s somewhere and can see it when I look at the brand. Other than that, did you download the right platform version?

Another thing to try: after closing VCV Rack, look in your user folder for the file log.txt. Reading this file should tell you whether (a) VCV Rack tried to load Monome Teletype but failed for some reason or (b) VCV Rack didn’t know it should try. Knowing which of these happened will get you closer to diagnosing the problem.

Have you included the dependency packages? Even if you didn’t build it, it still might need some sudo apt install ... etc. serialosc setup | monome/docs maybe?

Ok all good thoughts. Let me try some stuff. I definitely have the arm version and am on an M1 Mac. I did install serialosc even though that should only be needed for hardware. Let me check the log files - doh!

Aha. Mystery solved. Could not load plugin /Users/…/Documents/Rack2/plugins/monome: Plugin binary not found at /Users/…/Documents/Rack2/plugins/monome/plugin.dylib Let me see how to sort that out.

1 Like

Ok so the Intel version installs - which is really weird since I am definitely on an M1 Mac. But anyway sorted now albeit somewhat mysteriously.

The M1 version of the module is for the M1 version of VCV, I think you’re not running the M1 version of VCV.

And where would I get that from? The VCV site only seems to have one Mac download file. Sorry asking all the dumb questions today.

It’s in beta and for module developers :

Thanks everyone for resolving this quickly! The distinction between mac-x64/-arm64 builds seems to be a frequent source of issues, I will add a warning about this to the download instructions.

Serialosc is not a requirement unless you want to use hardware grids, the plug-in/modules will run fine without it. There shouldn’t be any dependencies necessary beyond what’s in the package.

1 Like

Hi! First time posting here :slight_smile: I’m having trouble finding Teletype in the library. After following everyone’s instructions I got to this message in the log file:

[2.435 info src/plugin.cpp:128 loadPlugin] Loading plugin from /Users/-------/Documents/Rack2/plugins/monome [2.436 warn src/plugin.cpp:194 loadPlugin] Could not load plugin /Users/-------/Documents/Rack2/plugins/monome: Failed to load library /Users/-------/Documents/Rack2/plugins/monome/plugin.dylib: dlopen(/Users/-------/Documents/Rack2/plugins/monome/plugin.dylib, 6): Symbol not found: __ZN4rack6engine13ParamQuantity17setImmediateValueEf Referenced from: /Users/-------/Documents/Rack2/plugins/monome/plugin.dylib Expected in: /Applications/VCV Rack 2 Free.app/Contents/MacOS/…/Resources/libRack.dylib in /Users/-------/Documents/Rack2/plugins/monome/plugin.dylib

I have no idea what that means or how to fix it. Any clues? Cheers!

That looks like a possible mismatch between the SDK that the plugin was built against and the version of rack you are running it against. I seem to recall some changes to ParamQuantity/setImmediateValue for Rack v2.3.0. What is the exact version of rack you are running?


Yup. Rack is not forward compatible, that’s how Andrew’s decided it, so if this plugin has used symbols introduced in Rack 2.3.0 then it won’t run on Rack versions lower than that. Morale: Always use the latest version of Rack or get occasional surprises.


Thank you for the replies! I’m on Rack 2.2, I’ll try updating to 2.3 and will let you know how it goes.

1 Like

It worked! You people are the best, thank you so so much!


Glad that got sorted quickly, thanks everyone! Yes, because of the API change, the latest version of the plug-in requires Rack 2.3.0, as described in the release notes:

  • Update to Rack 2.3.0 SDK (plug-in will not load on earlier versions.)
1 Like