Rack window focus problem [solved]

Hi all, since today i am having a problem where “something” within VCV is stealing focus of the cursor.

Only thing changed is 2 times updates from the plugin updater, which includes several plugins at once. Therefor i do not know what plugin might be causing this, if it is that anyway.

This problem only happens when VCV Rack is running. I am not experiencing this problem in Windows or any other application on my laptop when VCV Rack is not running.

Does anyone else experience this too? Windows 10/64

Does anyone know of a utility that can see/track what is taking cursor control?

Can you share your patch?
What does your cursor do when „the focus is stolen“?

Is your cursor disappearing after turning a knob? I had this happen last night like 3 times. I got it back by cmd+tab several times.

I see that i described the problem incorrectly, i have now edited the title of this thread to the correct description.

It is not the cursor, it is the Rack window itself that is loosing focus, So the color of the title bar changes to the unfocused color, as soon as i move the cursor (mouse) the focus returns to VCV Rack window, and then after a few seconds it happens again.

Thanks Ben, actually this question solved the issue. I am testing a new module, therefor i can not share the patch.

But your question, triggered me to think about the module itself which i had not considered.

I will now contact the developer and let him know. Thanks again!

Oops, i spoke too soon… After having the module and its copies removed, the problem still exists.

Ben, I will send you the patch in a DM

I don’t have the Prok modules but it doesn’t happen to me. I find it more likely this a caused by an application outside of Rack…

This only started happening since today after a recent list of plugin updates.

When Rack is not running I don’t have this issue. I can have several other applications running, but as soon as I start Rack this issue starts to happening, stealing focus from whatever window is active at that moment.

My guess it is one of the updated plugins that is causing this. I have now tested with a blank patch, and it still happens as soon as I started Rack.

Ok, this sounds crazy. Maybe you can remove the updated plugins one by one and isolate the misbehaving one…

That’s a problem, there were 2 updates I did these last days, for several plugins.

I would not remember which those were exactly. I wish there was a way to look back at a history of which updates were done…

Take a look here:

1 Like

I see, are you suggesting that the ones near the top of the list are the ones that have been updated recently, right?

Yes. But it might be the plugin you are testing. Maybe start with this one.

Ok thanks, I will check tonight and delete a few plugins.

I doubt it is the one that I am testing, as I am testing the same build for over a week now.

Thanks for the hint, and help.

Ok, so i narrowed down some things a bit. The issue i am having has nothing to do with neither Rack or a plugin.

Apparently the most recent update of Windows (version 2004) is causing something to misbehave on my notebook.

Already went through the process of reinstalling and updating NVIDIA. But it seems the problem is a bit deeper. Will have to take more deep diving into the system.


1 Like

Windows! :partying_face:

1 Like

I love Windows!

1 Like

So i managed to track it down to the Synaptics Touchpad driver. Apparently this 2004 update is quite significant.

So after i had reinstalled the original mobo chipset update, disabled several startup services that i wasn’t using anyway, disabled almost everything in the list of “O&O Shutup10”. :sweat_smile:

The only thing left that i was suspicious of was the touchpad. After uninstalling the Synaptics driver the problem was gone. So i guess i have to wait and look for a new updated version of that driver and its software.

I am leaving this here for reference.


edit: this is now fixed as well, i simply updated the PS/2 mouse entry in the device manager, with the original Synaptics driver that came with the notebook. Touchpad is working again as it should and all seems well and back to the state it was before this weird OS update.

The funny thing in this whole story, it was because of Rack that i noticed this problem. It wasn’t really apparent (yet) from using other applications. So… thanks VCV! :joy: :sweat_smile:


I do as well… except for the drivers, the 7 generations of UI, the global Registry database, the update procedure and delivery, the console, the companion applications, the ecosystem, the heavy legacy burdens, the historic shadyness of the company behind, the proprietary subsystems and interfaces, the hopeless string handling and encoding, its incestious relationship with hardware vendors, etc. etc. Apart from all that I love it and use (suffer) it for work 8 hours a day for more than 25 years :wink:

1 Like

Such a gem, a lovely Windows gem :wink: