Process VCV in Microbrute - I'm stumped!

Hi everyone

I’m trying to bring audio from VCVrack (or any soft synth source for that matter) into my Microbrute, so I can use the filter envelope on it, mix it with the Microbute’s own oscillator and things like that - as shown in this video (the last two tips at the end).

Using a PreSonus Audiobox, I was able to hear sound from VCVrack by plugging a USB cable from the Microbrute to a MacBook Pro, A USB from the PreSonus to the MacBook Pro, and 1/4 mono cable from the Presonus to the Microbrute. With the headphone plugged into the PreSonus, I can hear both sounds, and I think I can bring in the VCV sound into the MicroBrute because when I tweak the frequency of the VCV oscillator, I hear a sort of phasing effect. But I can’t affect the VCV sound in any way using the Microbrute.

I’d love to get the Microbrute working with an outside source because then if I start getting a few Eurorack models, I could use things like the Microbrute for filters etc.

This is the Presonus https://encrypted-tbn0.gstatic.com/images?q=tbn:ANd9GcTqTGPgQu_RlG5yFflCJnUD8LsfMRZTmPhtkgbMH-n6HOxdVBXpAuFYru3xwz74mVXtEf5vJ9Pd&usqp=CAc

And these are all the inputs on the back of the Microbrute

Any idea what I’m doing wrong? I’ve tried plugging so many things into so many different sockets (ahem) but just can’t get this to work!

Any suggestions hugely appreciated

By this, do you mean using the Microbrute knobs and faders to send midi to VCV ? Because that’s not possible, they are analog and don’t send midi

The keys and pitch/mod wheels work though

FWIW, the Minibrute audio out is line level.(pg.40 of: https://downloads.arturia.com/products/minibrute/manual/MINIBRUTE_Manual_EN.pdf) Not recommended to connect that to the Presonus audio in. Can I connect a line level source to my AudioBox USB or 22VSL? – Knowledge Base | PreSonus

edit: changed pg# above from 46 to 40

Oh jeez another layer of confusion for me, haha. Ok, so looks like a Direct Box is needed to connect the Microbrute to the PreSonus. Something like this maybe? Is this to prevent damage to the PreSonus or would it help with the original issues. Sorry, pretty clueless here!

It’s funny that when it comes to learning about synthesis and all that, it’s the connecting of ‘this device to that device’ that I find by far the most confusing!

EDIT: also, please excuse my manners. Thank you very very much for taking the time to help.

1 Like

I guess no? I was just trying to see if I could manipulate sound from a different source in my Microbrute. I had the wrong link for the video before, which I’ve fixed now (see original post) - that video demos what I’m trying to do, but I can’t recreate what he’s doing for the life of me.

Later on (probably much later on) I plan to start acquiring some Eurorack modules, so it would be nice to utilize the Microbrute’s oscillator and filter, as well as VCVrack. It looks like the Expert Sleepers ES-8 module can help with that?

EDIT: Forgot my manners - I really appreciate your time in helping me :grinning:

Hi @ManBearPigNick!

I think this is more of a MicroBrute or Presonus question (mods, should it be in Lounge?) but happy to help (though without a MicroBrute or Presonus I may not be that helpful).

Let-s simplify for troubleshooting purposes before trying to route audio back in. So:

  • Presonus to computer with USB
  • MicroBrute to computer with USB
  • Presonus Main Out (use the top one, it’s probably the L/1 channel) to MicroBrute Audio In with 1/4" cable (ideally TS [unbalanced])
  • Headphones in MicroBrute (not Presonus)

Run a saw wave (to make the filtering obvious–basically anything but a sine wave is good) from a VCV oscillator (say VCO-1) into Audio-8 with Presonus and an appropriate driver selected. At this point, two questions:

  1. Do you hear the saw wave (which should be going Rack->Presonus Out->MicroBrute In->MicroBrute filter/VCA->MicroBrute headphone out->headphones)?
  2. Does sweeping the MicroBrute filter change the sound of the saw wave?

If both are yes, we’ll figure out how to route back to the Presonus. Otherwise, we’ll troubleshoot :slight_smile:

1 Like

gc - thanks for reaching out!

Ok, did the set up you described, on VCV it looked like this

On the Microbrute, I had the envelope selected but with the envelope amount turned all the way down. On the filter, I have the envelope amount turned all the way to the right/positive.

I could make out a weak, high pitched tone. I could barely make out a sweep, but something seemed to be there. And on the envelope, I could take off the attack and hear the effect on the VCV’s oscillator.

For reference, the Microbrute’s controls are like this: MicroBrute Patch Configurator

Does that give a clue as to what is going on?

Thanks again!

1 Like

Hi! Thanks for the update. So let’s keep it as simple as possible for troubleshooting purposes–just route the VCO-1 saw straight into the device. Now the saw is droning and the only thing you’re doing in VCV is controlling amplitude with the 1 fader (good idea so as not to blow out your ears!)

I think the Patch Configurator link needs to be done with “Save” (so it gets an ?id= param in the link) so I can’t see how it’s currently set, but from a quick look at the manual I’d check at least the following things on the MicroBrute:

  • Make sure the Input Level knob is high enough (need to be popped out to adjust; manual p. 47);
  • Turn ENV AMT in the filter section to the 12:00 position (so the filter’s not waiting on an envelope) (manual p. 46);
  • Over in the Envelope section, flip VCA to the down position (Gate).
  • You may need to press a key to hear anything, as it doesn’t look like the VCA in the MicroBrute can be stuck open from the front panel (maybe in the editor?)

By now, you should have heard a clear strong saw signal. If so, play with the primary filter controls–I suggest selecting LP mode with some resonance and sweeping the cutoff–and see if that changes the sound. If not, we’ll keep troubleshooting!

Nothing is coming through at all. I just realized the sound from before was the Microbrute, even with all of the oscillator settings turned down. I disconnected the VCV oscillator and the sound was still coming through.

Sorry about that.

1 Like

Ah–makes sense. In hindsight that does sound like oscillator bleed. And it makes troubleshooting simpler because we know that audio is either not leaving the Presonus or not passing through the MicroBrute. So, it’s good news!

Assuming you hear the VCV saw in the headphone out of the Presonus, try the MicroBrute steps above. If I had to guess, I’d guess it’s the Gate issue–if the VCA can’t lock open and external audio goes pre-VCA then the synth has to have a high gate input to pass along the audio in.

If no luck after that, check the Presonus config. Some interfaces require extra routing to go through headphones vs. other outs. (Unlikely on a smaller unit but worth a look).

Ok I’ll try those steps tonight and let you know. Thanks!

gc, just followed the same steps, with the headphones in the PreSonus and I’m getting the VCV oscillator is coming through as a continuous, strong tone. Pressing the keyboard has no effect.

Also, in the Arturia’s midi center, there is a gate setting that can be set to short, med, long. I don’t think there’s any setting that holds the gate open though.

Hmm–what do you hear from the MicroBrute’s headphone output, though (with and without a keypress, and with the other oscs turned down)? With the routing we’re working with, nothing you do on the MicroBrute will reach the Presonus; it’s a one-way trip into the MicroBrute.

Apologies if I’m misreading you, just want to make sure we’re on the same page.

Assuming no VCV osc sound with headphones in the MicroBrute, try plugging your headphones (with the right adapter, of course) into the Presonus Main Out 1 (which you currently have connected to the MicroBrute). It may sound soft or only be in one channel, but see if you hear anything. We know the VCV signal is reaching the Presonus; we need to confirm that it’s leaving it via the main outs, not just the headphone jack.

It works

Don’t quite understand what I did different this time, but it must have been something! I put the headphones into the PreSonus Main Out and got sound. Then I plugged a cable from the Main Out to the MicroBrute In and plugged the headphones into the MicroBrute and got the VCV oscillator. Envelope and filters work on it. Have to keep a key down on the Microbrute to hear it though – seems to be the only way to keep the gate open.

Thank you so much for figuring this out!

1 Like

Fantastic! So glad to hear it’s working :smiley:

One next step might be getting the processed audio back into VCV (and/or the MicroBrute oscs). That way you can start experimenting with a hybrid setup (processing digital oscillators in analog, or analog filters in digital). Don’t hesitate to reach out if you get stuck on that, and watch out for feedback loops!

Regarding holding the gate open (if you just want to use the filter): I don’t know anything about the MicroBrute beyond skimming the manual, but short of taping/weighing a key down you could look into recording a looping pattern (without rests) in the sequencer. Whether (and how) the MicroBrute sequencer supports ties (notes longer than a single step) is down to how the details of how it’s been programmed, so you’ll have to experiment. VCA Gate is more likely to work for this than VCA Env.

Unless your interface is DC coupled (most aren’t) you won’t be able to send a steady gate to the back panel.

If there’s oscillator bleed that’s probably going to come through in each of these situations, but you can think of that as adding character to what you’re sending in; these days I take almost all of my digital signals out of the box just to tarnish their purity a little, even if I’m not looking for noticeable filter/etc. effects.

Have fun and enjoy the journey!

Thanks gc!

Those are definitely directions I’ll be exploring next and I’ll reach out if I get stuck :+1: :100:

1 Like