Problem with compile build VCV Rack

Hi everyone. I have a problem when I try to compile a VCV Rack (v1 & v2 - same problem) build via MSYS2 64bit version on my Win10 computer. I many times installed MSYS2 on my computer step by step use a recipe to building Rack on VCV Manual - Building. So finally i have the same result when I try make dependancies using make dep command I recive this

$ make dep make: cc: No such file or directory make: cc: No such file or directory make: cc: No such file or directory *** Could not determine CPU architecture of . Try hacking around in Stop.

Year ago I change only my old HDD and reinstalled system on new disk. Before everything works fine. But now nothing works. I have a 64bit W10.

Trying install Rack on different drive, catalogue, etc, … I would appreciate any advice on what to do in this case.

this could be a problem with github,

yesterday I couldn’t compile any plugins, but today they compiled fine so maybe it is just this,

but I would delete everything and try a fresh start first.

I can’t build any version of VCV Rack (v1 or v2) since I change system disk. I used this before for compile plugins for v.1.1.6 of Rack. I have this problem every time (last year) I want to try compile by my self some new plugins. And every time have this problem. It’s kinda frustrating. Because I don’t know what the problem is? I follow the recipe and nothing. The previous system was installed on the old disk but on a logical partition. And I wonder if that’s not a problem? Or maybe it doesn’t mean anything? But then everything worked, I was able to compile new Rack versions and new plugins.

Never had a problem. Did you install all the required tools using pacman?

Yes I installed all tools required - every time. I dont know how many times I installed MSYS2 in this year and how many I use all commands from manual :slight_smile:

Please post a screenshot of your cloned Rack directory. It looks like some files or folders are missing.

This is main msys64/home/jedrz/Rack

Ok, and the dep folder?


all for v2

You are calling „make dep“ from the command line within the Rack folder?

And you are using the MSYS2 64-bit shell?

no every time I’m in Rack folder and I use “make dep” command


Can you post a screenshot of the shell with the error message?

I try to change catalogue for example c:\V and clone inside VCV etc. riddle are still unsolved for me. :slight_smile:

This is the wrong shell, this is not the MSYS2 MinGW 64-bit shell!
Ist just says MSYS.

1 Like

maybe you have right. I will try this Yes It works. Thank you Ben. Oh! I was a blind man all the time. What a shame for me :smiley: Many thanks for advice. Shame On me :smiley: !! :vulcan_salute: :beers:

Glad I could help.

1 Like