Pitch CV in is sliding (latency?)

I’ve had Rack 2 for a while but never normally use it to take input CVs from the physical rack, however I tried that tonight and seem to have encountered an odd issue.

I’ve got a pair of tracks in Ableton, receiving audio from an ES-9 (well, actually, pitch CV and gate from a physical sequencer), those audio tracks send their audio to the track that has VCV rack on it, and an Audio-16 in the rack breaks those CVs out so they can drive the pitch and gate of a VCV voice (an elements).

I was getting all ultra-slid notes, I put a scope in the VCV and can see the pitch CV sliding, so I reset the physical sequencer (and tried another), at first thinking that it was me sending the slid notes in, but no, they are leaving the sequencer as normal un-slid notes, but the pitch CV in rack is sliding.

I had to kludge it for now by putting a sample and hold in VCV (gated by the physical sequencer gate coming in) to hold the pitch while elements plays a notes, this seems to work fine - I haven’t checked the tuning yet but it sounds ok.

I am guessing this might be latency, but I tried turning down the samples in the DAW to no avail.

Anyone seen this before or know how to fix it properly?

OK I just solved this myself, but posting back in case anyone needs it in future. It looks like my ES-9 config tool was telling me erroneously that the DC blocking was off for the relevant inputs, in fact it must have been on, because looking at the VU meter on the pitch CV track you could see it “falling away” after the note was sent, and sending a static fixed voltage into that port from the physical rack also helped diagnose that in fact a DC voltage wasn’t making it through correctly. I disabled and re-enabled DC blocking in VCV for the relevant inputs, and it started working correctly.