Only 12 VCV fundamental modules loaded, cannot update

VCV newbees here…rack 2 worked on my Mac with no issues. Just installed rack 2 on my PC running Win10. Just 12 of the fundamental VCV modules were in the library (see screenshot). I tried to update, it told me that all plugins have been downloaded and needed to relaunch, so I did, but still only 12 modules were there. Any ideas of what might be the issue here?

Thanks in advance!

Are your Documents “in the cloud” ? does your mac use the “same” folder ?

1 Like

Hi (and welcome here!)

Perhaps something abnormal from Documents\Rack2\settings.json file (kind of “whitelist” or similar, or corrupted file).

Try to:

  • Close VCV Rack 2.
  • Rename the settings.json file (mentioned above) to settings.old (or any you want).
  • Restart VCV Rack 2, log in (notice a new settings.json file will be automatically created).
  • Download/Udpate plugins/modules (top menu, where the red pill is).

When all downloaded; close and restart VCV Rack 2 (yep, this is required).

Hope it will help! :pray:

If the suggestions above don’t solve your problem, try closing VCV Rack, then look in your user folder for the file log.txt. You can use Notepad or your favorite text editor to open and read that file. Whenever Rack is acting weird in any way, reading the logfile often helps diagnose the problem quickly. Feel free to post any errors reported in the logfile here if you can’t make sense of them.

Hmmm that’s a good point…I think when I installed VCV in windows i specified the local C drive, but somehow the files that contains log and settings files all ended up in the H drive, which is a shared drive…maybe that’sthe soruce of the problem.

1 Like

Thanks a lot! I tried but didn’t work…I suspect the issue was what @Yeager mentioned above…do you know how to change the directory?

Thanks a lot! I was not able to open that file (see screenshot)…not sure why but I was able to open the setting.jason in the same folder.

Screenshot 2023-03-07 114905

Did you close VCV Rack first? You need to.

yup I did close it first.

That’s super weird. I guess reboot Windows and try opening log.txt again, without opening VCV Rack at all.

still the same issue…hmmmm… I will try to look into how i can move the folder from the shared drive to the local drive…maybe that was causing all the issues…

Not setting.jason (as you’ve wrote), but settings.json file.

Thanks for the clarification! Yes settings.json, not jason (typo!). The document fodler is on a shared (or cloud) drive, different from where the program was installed (which i specified when it was being installed)…do you know how to move the document folder?

Your welcome!

Avoid cloud storage for documents! this is a major source of issue against many softwares! useful only by manually sync. (you save outside what you want and when you want).

Can’t help more, because I don’t use cloud. Sorry, and good luck!

1 Like

Don’t use a cloud/shared drive.


That’s awesome! It worked. Thanks so much you guys!


Excellent news! :ok_hand:

Yeah. I seem to recall seing on my work Windows PC at some point during the last year or two, that Microsoft was pushing OneDrive very heavily onto people, to the point of being quite diffictult to stop it from running. But the worst was a “helpful” dialog popping up saying something like “would you like to move your documents to OneDrive? It’s sooooo good for you”, and I imagine lots of people having no clue what it means just clicking Ok. So devious and the most stupid idea ever, obviously breaking lots of applications. Microsoft over the latter years has become less of an evil, stupid company, but sometimes the old beast rears its ugly head, and innocent users pay the price.

I don’t know if your H: drive is on OneDrive but perhaps this is what happened.