old plugins not working

“Hello, I would like to ask for help on a forum regarding an issue I’m having with using modules such as Parable Instruments and mscHack in VCV Rack. I have tried several versions of VCV Rack but I am still unable to run my old patches. Could you please help me with this?”

If you still have the old Documents/Rack/ directory on your machine, or a backup, you simply re-install the old 0.x/1.x version of Rack (whatever version they’re made with) and use the old patches. You can’t use the old patches in Rack 2.x if the plugins are no longer available.

1 Like

You can run v1 and v2. I have hundreds of v1 patches and some of them open in v2. For those that don’t, I just run them in v1


As near as I can tell, only the old patches with v1 modules that have all been ported to v2 will work in v2. It will look like for all intents and purposes like a v2 patch. If you then modify it and save it, it will no longer open in v1. (At least that’s what happened when I tried an experiment, and it told me there was a “JSON parsing error at…”)

If it needs a v1-only plugin (like Aria Salvatrice, sadly) It opens with a warning and missing modules.

I’m glad I hung onto v1.

Well, always keep versions (installers, packages, archives, etc. etc.) of software and patches around!? Local duplicated storage is cheap, and people should finally understand that nothing on the internet will be available long term - not on Spotify, not on YT, not on Steam, not on vendors websites, not on your cloud account!

You can use the -u commandline parameter with a specific Rack version to specify a custom user directory, in order to keep all the version-specific plugins readily available.

If you don’t know what i am talking about - well, though luck, you have chosen to use software and thus have to acquire all associated knowledge - which is much more than for just using hardware.