NYSTHI v2.4.23

is not in the library you should get it from here

Antonio: yes - I got it from github:( the new windows one works on my windows machine but NYSTHI-2.4.21-mac-x64.vcvplugin doesnt show on Mac machine for some odd reason:(

Thanks Antonio! Unfortunately, the Programmer knobs aren’t working in the Win 2.4.21 release

1 Like

That is indeed odd. The new 2.4.21-mac-x64 version appears to be working correctly for me.

1 Like

OK! found the problem… so:

  • works on my PC
  • works on my M1 mac
  • DOESN’T show on my old High Sierra (10.13.6) Mac
  • 2.1.19 works/shows on my old High Sierra (10.13.6) Mac

Antonio: any chance you can fix it for High Sierra?! I still use that machine from time to time…:slight_smile: and previous build worked just fine. Could be a flag in the compiler?! Thank you! (if its not possible, thats it, no worries…)

is it an intel or m1 ? (the high sierra)

in case of intel you sholud use the x64 version

nooooooo I was 100% sure about the correction

did you try in a new patch?

Antonio: High Sierra machine is Intel and yes I tried the x64 version. It doesn’t show:( It’s smth that High Sierra doesnt like for some reason… BUT as I said, v 2.1.19 shows/works on that machine! Smth is in what you changed in latest build it seems.

It was in a new patch. In Rack Pro standalone 2.4.1, Windows 10

1 Like

the only difference in the build is the SDK (I have an M3 with last XCODE and can’t go under sdk 14.2


  cmdsize 16
  version 10.9
      sdk 14.2

vers 2.1.19

  cmdsize 16
  version 10.9
      sdk 12.1

What is “smth” ?

Have you permanently stopped submitting releases to the library Antonio? And if so, may I ask why?

please try this version

1 Like

I never received OK on all 4 platform

I can’t give OK to release in the LIB if there are known problems

1 Like

Hooray, the Programmer knobs are turning!


arm64 so far all fine, as was the 2.19 arm64 build.

1 Like

@chaircrusher I’ve added something to your preferred wobbling clock “RAEL”

the wonkiness recoverable in a certain number of loop

I downloaded it & it appears to be running the right version but I can’t see any of those Rael options in the menu.

I also must say I’ve read your description of that feature & have no idea what you mean I immediately lashed something up to try it but no joy so far.

you should see something like Screenshot 2024-02-06 at 12.47.40

if active will try to recover all the randomness at the end of X loops (where x is decided in the loop menu)

means that the clock is WOBBLING, but every X loops will sync perfectly to a steady clock (It’s my hope) :smiley:

1 Like

Antonio: that RAEL module is very enigmatic:) can you, by any chance, share 1-2 very simple examples as vcvrack2 files that show its power? thank you.

It’s a very simple utility module containing 12 lines equivalent

the button on the left is to TRIG (or using the input), if the line is ACTIVE, after the TRIG, and after the DELAY in sec the GATE will be set ON for DURATION secs. A TRIG is emitted at END of DELAY and another one is emitted at END of DURATION of the GATE.

The line can be looped (the EndOfGate is connected to the TRIG input)

DELAY of action and DURATION can be randomized using probabilistics fields from 0.0 to 1.0

PROB 1.0 means: use the same value PROB 0.0 means fully random of the current value (the computed display show the values after probabilities)

formula precise is VALUE * PROB + VALUE * 2 * RAND(1.0 - PROB) example you have a DURATION of 5 secs and probability of 0.80 means: 5 * 0,8 + 5 * 2 * RND(0.2) → duration will have MIN 4 to a max of 6 secs

When SEQUENCE is on, previous EOG will trig next LINE

If a clock is in distance between clock impulses is computed as a TIME base (values of DURATION and DELAY are not anymore in SECONDS but in fraction of the TIME BASE

can be a Trigger Delay Gate Delay Clock Trig sequencer Gate Sequencer Wonky clock