Not getting the performace I would expect

So I was previously running a laptop with the following spec:

System:    Host: hyperion Kernel: 5.0.0-23-lowlatency x86_64 bits: 64 gcc: 7.4.0
           Desktop: KDE Plasma 5.17.0 (Qt 5.13.1) Distro: KDE neon User Edition 5.17
Machine:   Device: laptop System: Hewlett-Packard product: HP EliteBook 8570w v: A1029D1102 serial: N/A
           Mobo: Hewlett-Packard model: 176B v: KBC Version 50.1B serial: N/A
           BIOS: Hewlett-Packard v: 68IAV Ver. F.41 date: 05/20/2013
Battery    BAT0: charge: 62.8 Wh 98.4% condition: 63.8/63.8 Wh (100%) model: Hewlett-Packard Primary status: N/A
CPU:       Quad core Intel Core i7-3720QM (-MT-MCP-) arch: Ivy Bridge rev.9 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 20752
           clock speeds: max: 3600 MHz 1: 2976 MHz 2: 2561 MHz 3: 2884 MHz 4: 2664 MHz 5: 2824 MHz 6: 2894 MHz
           7: 2078 MHz 8: 2890 MHz
Graphics:  Card: NVIDIA GK107GLM [Quadro K2000M] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 ) drivers: nvidia (unloaded: modesetting,fbdev,vesa,nouveau)
           Resolution: 1920x1080@59.98hz
           OpenGL: renderer: Quadro K2000M/PCIe/SSE2 version: 4.6.0 NVIDIA 430.26 Direct Render: Yes
Audio:     Card-1 NVIDIA GK107 HDMI Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Intel 7 Series/C216 Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-3 Focusrite-Novation driver: USB Audio usb-ID: 003-004
           Sound: Advanced Linux Sound Architecture v: k5.0.0-23-lowlatency
Network:   Card-1: Intel 82579LM Gigabit Network Connection (Lewisville)
           driver: e1000e v: 3.2.6-k port: 5040 bus-ID: 00:19.0
           IF: enp0s25 state: down mac: 2c:44:fd:65:23:13
           Card-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi bus-ID: 25:00.0
           IF: wlo1 state: up mac: 3c:a9:f4:4f:0d:0c
Drives:    HDD Total Size: 1250.3GB (67.4% used)
           ID-1: /dev/sda model: CT250MX500SSD1 size: 250.1GB
           ID-2: /dev/sdb model: TOSHIBA_MQ01ABD1 size: 1000.2GB
Partition: ID-1: / size: 34G used: 14G (41%) fs: ext4 dev: /dev/sda3
           ID-2: /home size: 81G used: 48G (60%) fs: ext4 dev: /dev/sda4
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 57.0C mobo: N/A gpu: 0.0:51C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 279 Uptime: 7:33 Memory: 4066.2/11937.3MB Init: systemd runlevel: 5 Gcc sys: 7.4.0
           Client: Shell (bash 4.4.201) inxi: 2.3.56

I decided to buy a desktop because I thought I would be able to do more and got the following:

System:    Host: hyperion Kernel: 5.6.17-rt10avl1 x86_64 bits: 64 compiler: gcc v: 8.4.0 Desktop: KDE Plasma 5.19.4 
           Distro: KDE neon 20.04 5.19 base: Ubuntu 20.04 LTS Focal 
Machine:   Type: Desktop Mobo: ASUSTeK model: PRIME A320M-K v: Rev X.0x serial: <superuser/root required> 
           UEFI: American Megatrends v: 5409 date: 01/07/2020 
CPU:       Topology: 8-Core model: AMD Ryzen 7 2700 bits: 64 type: MT MCP arch: Zen+ rev: 2 L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 102197 
           Speed: 3418 MHz min/max: 1550/3200 MHz Core speeds (MHz): 1: 3418 2: 3349 3: 3294 4: 3134 5: 3015 6: 3471 7: 3062 
           8: 3438 9: 3374 10: 3287 11: 2817 12: 3293 13: 2821 14: 3538 15: 3335 16: 3368 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Baffin [Radeon RX 550 640SP / RX 560/560X] vendor: XFX Pine 
           driver: amdgpu v: kernel bus ID: 07:00.0 
           Display: x11 server: X.Org 1.20.8 driver: amdgpu FAILED: ati unloaded: fbdev,modesetting,vesa tty: N/A 
           OpenGL: renderer: Radeon RX 550 Series (POLARIS11 DRM 3.36.0 5.6.17-rt10avl1 LLVM 10.0.0) v: 4.6 Mesa 20.0.8 
           direct render: Yes 
Audio:     Device-1: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X] vendor: XFX Pine driver: snd_hda_intel 
           v: kernel bus ID: 07:00.1 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 09:00.3 
           Device-3: Focusrite-Novation Focusrite Scarlett 6i6 type: USB driver: snd-usb-audio bus ID: 3-4:4 
           Device-4: Focusrite-Novation Launchpad MK2 type: USB driver: snd-usb-audio bus ID: 3-3:3 
           Sound Server: ALSA v: k5.6.17-rt10avl1 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: e000 
           bus ID: 05:00.0 
           IF: enp5s0 state: down mac: d4:5d:64:a7:8a:e2 
           Device-2: Realtek RTL8192EE PCIe Wireless Network Adapter driver: rtl8192ee v: kernel port: d000 bus ID: 06:00.0 
           IF: wlp6s0 state: up mac: 50:2b:73:d8:07:13 
Drives:    Local Storage: total: 1.14 TiB used: 885.31 GiB (75.7%) 
           ID-1: /dev/sda model: 256GB PCS 2.5 SSD size: 238.47 GiB 
           ID-2: /dev/sdb vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB 
Partition: ID-1: / size: 159.54 GiB used: 62.41 GiB (39.1%) fs: ext4 dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 32.2 C mobo: N/A gpu: amdgpu temp: 38 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 1188 
Info:      Processes: 397 Uptime: 3d 6h 29m Memory: 15.64 GiB used: 6.66 GiB (42.6%) Init: systemd runlevel: 5 Compilers: 
           gcc: 9.3.0 Shell: bash v: 5.0.17 inxi: 3.0.38

However, I’m not really seeing much improvement, patches which were pushing the limits on my laptop are still pushing the limits on my new pc. I have attached an example, I don’t think it’s particularly large but I am still getting slowdowns and glitches even with JACK set to 2048, periods 3, 48khz.

The realtimeconfigquickscan shows all green and no issues (except it says to set IRQ value which I haven’t looked into yet) so I assume there is not a problem with configuration. granny2.vcv (97.1 KB)

I feel like I’ve just wasted a load of money with the only benefit being less fan noise.

What else can I do? Set cpu flags and compile myself?

Have you tried all the tips in the manual? Searched for other answer here or on FB?

Have you set to realtime priority and tuned the number of cores in the engine UI?

Have you turned on the CPU meters to see if you problem is one or two “cpu drain” modules?

Yes, I have tried everything I’ve looked for. This has always been a general issue so I’ve always been on the lookout for ways to squeeze more out of Rack.

The realtime option in Rack causes a crash. On my old laptop this option causes whole system freezes and major instability, and (as far as I remember reading) Vortico will be removing this option in Rack 2 so I don’t think it’s worth playing with.

The CPU meter is what confuses me as there is nothing which appears to be that demanding. I’m not sure how to read it, I thought that the Audio module shows a total but this patch is not even going past 25%. On my system monitor it’s showing as 58%.

I’m no linux-guy and I can’t help you but I think there is something wrong with you setup. I’m on Windows 10 and I’m running your patch on my laptop (i7-8650U CPU @ 1.90GHz) with 2 threads enabled now for several minutes without one glitch (using WASAPI buffer 512 samples).

1 Like

Have you tried not starting jackd and only using Alsa? (that works better for me)

In early Rack versions the Audio showed total, but in later versions it doesn’t.

The patch is also running fine on my laptop (i7 6600U), Win 10, 2 threads, WASAPI

I’m on Linux… i7-2600 @ 3.40GHz 44100, 1024 buffer size, 4 periods

Granny patch was sad and glitchy with 1 thread, played fine for 10 minutes with 2 threads, my CPU fan sounded like it was going to take off, but there were no xruns or audible glitches. Nice patch. I turned it down to 124 and cranked the VCF on the bottom row wide open.

1 Like

I did try this but it didn’t make much positive difference.

yeah, those CPU meters look fine, I agree. I don’t think it’s that important, but the realtime option works just fine for me (on windows).

1 Like

I have the patch running on my Ryzen 5 4500 Laptop with 2 threads and 256 block size on Win 10 without any problems.

1 Like

realtime causes VCV to crash?

Indeed, there seems to be a problem with your system somewhere, your patch runs fine here, 7.8% CPU

To fine tune my setup I have these set up notes in my install for audio

  1. Edit /etc/security/limits.conf to add (needs relog to activate). This fixes memory allocations issues with JackAudio

chris - rtprio 99

chris - memlock unlimited

chris - nice -10

Shouldn’t need more than two or three threads up in the VCV settings menu…