MSYS2 installation error.

I’m running Windows 11 22H2, Build 22621.1776, I’m having issues with installing MSYS2, I know you aren’t the makers of MSYS2 but some of you might’ve had the same issue as i have, and I really need to install this so I had to resort to here.

At around 50% completion of installing MSYS2 this error pops up:

"Error during installation process (com.msys2.root): Execution failed (Unexpected exit code: 1): “C:/msys64\usr\bin\bash.exe --login -c exit”

I tried pressing “Retry”, but it didn’t work. “Ignore” just cancels the installation.

Whenever i press “Retry”, this pops up in the “Show Details” log: e[He[2Je[3J

Full “Show Details” log:

Preparing the installation…

Preparing to unpack components…

Unpacking components…

Extracting “20230526msys64.7z”


Installing component MSYS2

Copying skeleton files.

These files are for the users to personalise their msys2 experience.

They will never be overwritten nor automatically updated.

‘./.bashrc’ → ‘/home/Luigi/.bashrc’

‘./.bash_logout’ → ‘/home/Luigi/.bash_logout’

‘./.bash_profile’ → ‘/home/Luigi/.bash_profile’

‘./.profile’ → ‘/home/Luigi/.profile’





Writing maintenance tool.

Installation finished!

Any help would be appreciated, thanks.

Also, I’ve tried deleting the MSYS64 folder, no luck, ran it as administrator too.

I’m gonna try on another system running Windows 10 22H2