Monome modules dev log

In my Seq++ I made every key re-mappable using a user provided JSON file. I also had issues with stealing keys in ways that could be annoying.

1 Like

New release posted on GitHub:

  • updates the Teletype firmware to the latest post-4.0.0 bugfixes
  • adds a handful of mode shortcuts to the right-click menu, to act as a cheat-sheet for learning how to get around in the interface, but also to provide an alternate way of accessing the scene save mode if your OS blocks Alt+Esc.

Thank you.

1 Like

New alpha release here. Lots of new stuff, including Teletype scene import/export and grid improvements. This will probably be the last v1 update, working on v2 already.

Changelog from v1.0.0-alpha1 to v1.0.0-alpha2:

Highlights include teletype scene import/export, improved grid communication, 256 support including a virtual 256, and lots of bug fixes.


  • Import and export scenes from the right-click menu. Individual scenes can be read from/written to text files, or the entire set of scenes can be synchronized to a USB stick for exchange with hardware.
  • Copy active scene to the clipboard / paste active scene from the clipboard (a @scanner-darkly suggestion)
  • Re-focus the screen after using a right-click keyboard shortcut
  • Fix: restore M timing immediately when loading a patch
  • Implement DEVICE.FLIP (#66)


  • Rewritten grid-module serial communication layer
    • Adds support for 256 hardware (#28)
    • Restores support for Series and 40h grid hardware (#44)
      • note: not all module firmwares support 64/256, see #61
    • Fixes stuck notes in earthsea (#59)
    • Fixes flickering on 40h grids (#36)
    • Provides additional thread safety (#42)
  • Fix: eliminate a potential crash when unplugging a hardware grid from USB
  • Fix: update the VCV Rack patch correctly when manually reassigning a grid to a new module
  • Fix: always clear grid when disconnecting, regardless of method
  • Virtual grid improvements
    • Virtual 256 added (#28)
    • Selectable LED color and protocol in right-click menu, for older device emulation (#44)
    • Revamped aesthetics
    • Deadzones between keys removed, entire surface is clickable
    • Improved dragging behavior


  • Use double-precision floats for internal clock phase in all modules
  • Display module firmware version & git commit hash in right-click menu
  • Fix: preset glyphs are saved correctly in trilogy modules (#6)

Here are plug-in builds against 2.git.042a9ce0 for anyone motivated to try these out in v2.

<removed, see latest post>


hmmm, they are loading and seemingly function (short test) but no labels or anything else makes em look a wee bit not right, some more work to do there methinks. This is The latest posted Rack2 beta on win10

I think the lack of labels is intentional, he’s following the look & feel of the original hardware. As Michael recommends, I had to read the manuals for this stuff to understand at all how it works. Teletype is a lot of fun, btw.

1 Like

aha! Guess I never noticed these in v1. more to explore and manuals to read then, thanks for pointer

1 Like

I can’t build nor find a build for Mac here on Rack V2.

There are labels, they’re just subtle; as @dlphillips mentioned, the hardware look is intentionally minimalistic.

Click the link in my previous post and scroll down to the Artifacts section, all three platforms are there.

Note that the v2 build includes three unreleased modules that aren’t in v1—ansible, faderbank, and teletype expander—so don’t be surprised if those aren’t fully functional.


all good, will dig in, but at full zoom. Might make things a touch more clear, though still must read manual

Yep, these modules reward practice and study; not that plenty of other modules don’t also do that, but there’s a higher initial learning curve here than, say, a VCO.

So for anyone approaching these for the first time, please do share your questions, things you found initially confusing, “aha” moments you had, etc., so I can improve the Rack-specific learning experience!


The Mac file doesn’t work for me. There is nothing in the firmware directory. Tried to build it myself and get the same result. Make will not build the files in the firmware directory.

Am I doing something wrong? I’m on 10.13.6. Version 1 works fine btw

1 Like

Good catch, sorry about that. Try this build (for Rack v2.git.042a9ce0) instead: Use v2 arch variables in firmware makefiles · Dewb/monome-rack@68ba78a · GitHub

Works great now! Thanks for these. They were confusing to me at first. Glad I stuck with it. Looking for to playing with Ansible. Thanks again!

1 Like

On Windows 10 I’m seeing the following behavior when loading Teletype in Rack 2:

1 Like

That’s some quality static! Can’t reproduce on my Windows 10 machine, is there anything notable in the logs (or in the console output if you start Rack with make run?) Are you using Rack v2.git.042a9ce0?

1 Like

Ah! Found it:

[2.995 info src/common/FirmwareManager.cpp:180 load] Loading module firmware from C:/Users/theli/Documents/Rack2/plugins/monome/res/firmware/teletype.dll
[2.995 warn src/common/FirmwareManager.cpp:193 load] Failed to load library C:/Users/theli/Documents/Rack2/plugins/monome/res/firmware/teletype.dll: 126
[2.995 warn src/common/FirmwareManager.cpp:240 load] Could not load firmware teletype

Opening the folder shows an empty firmware folder. None of the plugins were loading after I posted that report.

Yep! I just redownloaded the artifact and reinstalled. Now the firmwares are showing up in that folder. I wonder what went wrong during the file extraction?

Anyway, very excited to have pretty much a full Teletype again. I used to have the hardware module and this works exactly the same.

1 Like

One more: Does Ansible have key combos to select the Key1/Key2 buttons? I’m trying to open the Meadowphysics options menu to change the output type via the virtual grid, but as soon as I let go the virtual grid snaps back to the main interface.

Also, when changing the active Mode on Ansible, the button seems to be double-triggering. The new app will show up (like switching from Kria to Meadowphysics) but then the interface will change to an options menu. Clicking Mode again will then snap it back to the app’s main interface.

EDIT: Sorry, another. On Ansible’s Meadowphysics, it seems like Key 1 and Key 2 are swapped vs. what the documentation says (meadowphysics | monome/docs).

Ansible isn’t ready for general use yet, it’s disabled in the v1 builds and it’s only back in the plugin.json in the v2 branch because I wanted to make sure it still worked, and tooltips etc. got updated at the same time I did the other modules. Yeah, those challenges with the keys and double-triggering the mode key are known issues.