Mixmaster - Using Direct Outs turns off channel meters?

@marc_boule so long as I’m being a pest: If I use the direct outs (to do the aforementioned thing with RackWindows Console) the channel meters are bypassed. Is that intentional? Can I get them back without you having to do any more coding? :wink:

Hmm, you mean the insterts? If you are refering to those, unless you’re feeding the signal back into the inserts after processing, the track VUs will unfortunately be off since you’re interrputing the signal flow in the track sections. If you really mean direct outs, then it would indicate a bug, since the VU meters should not be affected by the direct outs.

I think what you are trying to do is quite difficult, since the effect you want needs to have all the channels separately, but then you still want to be able to see and control individual tracks in MixMaster. Not at all obvious as to how that can be setup in the current state of things, unfortunatelty, as I understand it at least.

In other words, it’s hard to reconcile Airwindows Console with MixMaster since Airwindows is not a track-specific effect, it needs to have all tracks and it mixes them together and adds an effect (from what I understood). I don’ think we can then separate those tracks again to be able to process them individually (faders, VUs, etc) in MixMaster, before then being mixed again in MixMaster.

Never mind, I’d turned on “Cloaked Mode” without looking up what it meant :wink:

1 Like

RackWindows Console does work on individual tracks. And the Mixmaster Poly Direct Outs are PERFECT, because they default to ‘After Mute/Solo’ which I take to mean “After all the channel strip processing.” The master fader on MixMaster is taken out of the signal path entirely, which is too bad, but if you’re barmy enough to try and use RackWindows Console for summing, it’s a small price to pay.

The direct outs are pre master fader (and have to be) because the master track is where all the other tracks are summed to stereo in MixMaster. The master fader controls the level for that summed stereo signal. (You probably know this but just clarifying)

1 Like

In case anyone wonders about the seemingly undocumented “Cloaked mode” menu option and stumble upon this topic (like I just did xD), the answer is in MixerCommon.hpp:

// turn off track VUs only, keep master VUs

There are some newer features on MixMaster that haven’t made the manual yet, but this is not one of them :slight_smile:

From page 5 of the manual (Quickstart):

Other ways to save CPU

• Turn on Cloaked mode in global settings which turns off all VUs except for the Master VU (it also turns off CV viz)

and from page 10:

Cloaked mode (Global Setting)

Cloaked mode turns off all VUs except for the Master VU which can save a little CPU.

As this thread has come up again, for anyone stumbling upon this now, I should point out here that since this post was made, the Master fader CAN now be used when using the RackWindows Console for summing. To do so, take the stereo output of Console back into the Chain input of MixMaster. Then in MixMaster’s Master track menu settings, turn on “Solo chain inputs”.

Err… looks like we haven’t the same manual then ? :thinking:

Ok, after further research I assume you’re referencing this one MindMeldModular/MindMeld-MixMaster-Manual-V1_1_4.pdf at master · MarcBoule/MindMeldModular · GitHub ? If yes, github doesn’t want me to read it - it just tells me “something went wrong” and kindly suggests I retry… lather, rinse, repeat :-/

Hmmm - that’s odd - when I click on the link you posted it opens the manual PDF fine (see grab below)

Here’s a download link for the manual which should be good for the next 7 days

Hmmm - that’s odd

Yeah, it’s been doing this to me for a few days now… Not sure what’s wrong O_o

Thanks a lot for the pdf, I’ll surely have a use for it :+1:

1 Like

FYI, it’s not loading for me in Edge too. I just loaded FW’s Seeds Of Change pdf from github, and that worked OK, so it’s not a problem with all PDFs.

As a workaround, I just use the Download button to bring the MM file to my PC, then it opens fine in Edge.

1 Like

As a workaround, I just use the Download button

Duh ! And I’ve been a dev for 20+ years… What to say ?

Haha - I almost mentioned the download button but I figured if the PDF wasn’t loading in the browser for some reason then the download link might not work either.

Are you using Edge too Bruno?

Thanks Paul - I’ll look into it. And there was me thinking the days of basic web stuff not working properly with Microsoft browsers were over…wrong!

Just a thought - could it be a file size limitation on served files do you think? PDFs are so standard that I can’t really think of another reason why Edge wouldn’t open it when served from a server but will open it fine once downloaded to the client.

Edge is chromium-based now, but I don’t know if Chrome has the same issue.

Possibly, worth checking.

Works fine in Chrome for me (Mac)

I figured if the PDF wasn’t loading in the browser for some reason then the download link might not work either

It does - shame on me xD

Are you using Edge too Bruno?

Nope, this is on firefox (87.0). Didn’t try with other computers as I assumed the issue was on github - and also I thought this was only a PDF version of what doc was already available as text on the github page.

I’ve also noticed pdfs not loading when viewing them in github, for me it was the News of the Rack that was problematic, so it’s probably a github thing; but the download button was the solution as mentioned.