MacOS VCV rack app startup


(SP12) #1

Hi,
something preventing me from starting VCV Rack:
app icon jumping in dock. Thats it.
Any help?

cheers

W

macos 10.13.6 latest updates


(Nik Jewell) #2

Try deleting autosave.vcv ?


(SP12) #3

where to find it? actually its only the app and it never started at all.


(Andrew Belt) #4

Nobody has solved this to my knowledge. Unless I’m wrong, you’ll have to wait for Rack 1.0.


(SP12) #5

Damn. Can´t wait:D

Hope this will be really soon.


(Roman Novikov) #6

Umm… Check the log in /Documents/Rack? Even build it from source?


(SP12) #7

last entry in the log is: [1.168 info src/bridge.cpp:339] Bridge server started

and, no. just downloaded the last dmg version from the website.


(Roman Novikov) #8

What’s strange, usually Rack starts exactly after the bridge server has started, and this is a rare problem.
I don’t know, you can try build VCV from sources and see how it works for you– this is relatively easy even if you don’t know how to do it. Also you can build 1.0 version to play with it, but it has only Fundamental modules for now.


(Alan Holding) #9

Hi. Apologies if you did this already, but when you installed Rack did you copy the VCV-Bridge VST files to the VST folder? See the attached screen shot.


#10

Have you try to move the .app on the desktop and right click/open ?


(skar) #11

Hi everyone,

Came here to say that I’m encountering the same issue on my Mac. I tried to build VCV from the sources but it doesn’t work either…
Anyone kind enough to help? :slight_smile:


(Andrew Belt) #12

That’s interesting. Could you launch Rack in a debugger (lldb or gdb from Homebrew), hit Ctrl-Z in the terminal when it hangs, and inspect the threads with info threads and frames with frame?


(skar) #13

Sorry I’m a bit of a moron with Terminal… I’m unable to get anything about Rack from “info threads”/“frame” once I hit ctrl+Z


(Andrew Belt) #14

What debugger are you using?


(skar) #15

I’m using LLDB. What I get after leaving the process is what looks like a generic page either on info threads and frames


(skar) #16

@Vortico using the MacOS task manager I was able to extract these informations about the Rack process while it was hanging :

https://pastebin.com/HNUQBX9W


(Lars Bjerregaard) #17

It happened to me on my Mac a couple of weeks ago. It coincided with the machine starting the download of a system update. When it had rebooted the problem was gone. Go figure…


(Andrew Belt) #18

Could you send a screenshot of the Audio and MIDI devices in the “Audio MIDI Setup” app in the /Applications/Utilities folder? I suspect a particular audio or MIDI driver is preventing Rack from opening on MacOS.


(Tomektam) #19

I reallized that any empty folder in plugins solves this problem - maybe not too elegant way, but always :wink: You’ll get a something like this message: “Could not load plugin /Users/id/Documents/Rack/plugins/empty_folder_name. See log for details.”. Confirm OK button and voilà. Some inconvenience is the necessity to force exit from the application. BTW, for about two weeks I have this problem on 3 different Mac machines.


(Michael1964) #20

I don’t see that this has been mentioned, but for anyone that is having the issue, where are you running Rack from?

Due to the security changes in Mac OS, if you try running certain applications from a location other than the Applications folder they will not run. For some apps, there is no error message, just the icon bouncing in the dock then nothing.