MacOS Catalina non-Plugin Library/3-rd Party Plugin Issues

I’m seeing two issues with running Rack on Catalina: 1) “plugin.dylib” cannot be opened because the developer cannot be verified, and 2) Library, Update all appears to work without an error, but doesn’t actually update updateable plugins as next run shows same update(s) available. I’ve updated my System Preferences to allow apps to be downloaded from app store and identified developers. I also initially run Rack via Finder via RMB+Open.

I renamed the plugins-v1 folder to plugins-v1.old and reran Rack, and updated all Plugin Library plugins and they all installed as expected and Rack worked as expected upon restart. Rack and official plugins work behave as expected.

The offending plugins were 3rd party plugins not distributed via the Plugin Library – most of which were paid plugins (I won’t name names). If you have paid plugins consider distributing throught the official Plugin Library. Otherwise, sign your plugins so they’re compatible with latest MacOS (or kindly refund my $$ ;-)).

Happy Patching, all…

1 Like

Just solved this for myself! How I did it:

  1. Run VCV Rack, view the error message
  2. Open System Preferences -> Security & Privacy
  3. In the lower section, “Allow apps downloaded from:” you should see a message specifically naming the offending plugin. Unlock to make changes, hit the accompanying “allow” button, and restart VCV Rack. Problem hopefully solved!

Here’s an alternative that I just tried successfully with the new public beta of Atelier:

  1. Open Terminal and cd to the folder containing the plugin’s zip file.
  2. Run sudo xattr -d (changing “” to the file’s actual name, of course)
  3. Move the zip file to the plugins folder if it’s not already there and run VCV Rack. It should work without any error messages.