LowFatMilk Updates

The problem isn’t that big it needs symbolic links. I already have a solution running on my local branch. No worries.

1 Like

A new version of LFM 2.1.7 has been released. It now has the functionality to create your own playlists. See the manual for a description how it works. Curious to hear what you think of it. I also fixed some minor issues and added some smaller functionalities. Enjoy!!


And another release of Low Fat Milk has been uploaded to the library. This was needed as I spotted a bug that caused crashes when selecting a visual from the menu. Some more changes in this version:

  • Changed menu to be clear between visuals and presets
  • Selecting visuals from the menu caused crashes
  • If playlist mode active whilst closing, next and prev work properly when restarting
  • When playlist is active whilst closing, the active visual will be active again when restarting

It is great to see more videos coming online with LFM in it. Please let me know if you would like to see some more functionalities added.


Have updated to 2.1.8, restarted rack, prompted to update to 2.1.8 again etc. Linux.

The following issue has been raised by @docB , where some frames in LFM are black causing flashes. The effect has been captured in the below video. I see the same effect on my Linux box, but I can’t produce it on my windows machine.

I would like to know if other users have seen the same behaviour. And if so, I would like to see what your configurations are. For now what I would like to know is what OS you are on (including version) and what video card you are using and if possible the driver version.

Thanks for your help.

I’m having the same problem under Linux (Mint 20.2,based on Ubuntu 20.04 LTS): LFM refuses to update and the rack log file contains a “… version ‘GLIBC_2.35’ not found, required by …/RPJVisualizer/plugin.so” warning. Looks like the plugin has been build using a too recent version of GLIBC, making it incompatible with Linux distributions that are slightly older (but still used a lot). I’ve seen the same problem with the Blamsoft XFX plugins (see Blamsoft is back thread ).


Yes, you are right. My latest automated builds are built using the latest available os.
I will work on a new version that will build with older os. Hope that will fix the issues for you.

1 Like

I have uploaded new builds to my Google drive. Can you please test if this version works for you? If so, I will ask Andrew to deploy again to the library.

LowFatMilk - Google Drive

Fixed it for me. Thanks! Running MX Linux Wildflower (Debian 11.6)

1 Like

The new build also fixed it for me. Updated flawlessly (no more GLIBC warnings) and runs as expected on my Linux Mint 20.2 (Ubuntu 20.04 LTS based). Thanks!

1 Like

Version 2.1.9 of Low Fat Milk has been released. The following fixes have been implemented:

  • Github builds with older platforms instead of latest
  • Size of embedded window is restored when restarting rack
  • Incidental black frames on Linux fixed (kudos to @docB for raising the issue but also pointing me to the right direction for solving)
  • LFMEmbedded blacked out if left-side controls where out of view

Hi Robert,

I don’t know if I’m doing something wrong, but I only see one preset and that’s with a flying M with headphones. If I click Next or Previous, nothing happens. Not even when I select presets in the menu via the right button.

I’m using Windows 10, VCV Rack Pro 2.3.0, RPJ Visualizer 2.1.10

Thank you for answer.

You can’t do much wrong here. The behavior you describe normally would happen if the module can’t find the presets. So what you could do is see if some rights are set differently in the plugins folder. If you are an experienced user you can use a windows tool that can tell you if there are access issues (filemon). Looks to me something exceptional in your config.

Thanks for your reply Robert,

I thought of one thing that could prevent the presets from being found. The plugin is located in this path C:\Users\Vašek\Documents\Rack2\plugins\RPJVisualizer

Could the folder name “Vašek”, where the letter “š” is used, be a problem? I’m not a programmer, but would some Latin Extended support help?

You’re right that that’s the likely trigger for a bug in path/text handling somewhere in the software. The question is if it’s a bug in Rack, the plugin, or one of either’s dependencies.

There are plenty of software around with this particular issue, but it’s still a bug. There should be nothing wrong with spelling your name the way you spell your name. Unicode is a generation old now, but somehow software still needs to catch up.

Of course, you can simply stick to plain ASCII for your user name and sidestep this distressingly common issue.


Shut down rack, if it’s running.

make a copy of “C:\Users\Vašek\Documents\Rack2” to "C:"

add a user environment variable to point to the new user dir.

Win+X → Settings → Advanced System Settings → Environment Variables
under “User variables for user …” → “New”

Start rack

If it works, you can delete C:\Users\Vašek\Documents\Rack2

docu link

1 Like

Yes it could. There have been many many examples of usernames with unicode causing troubles for Rack or plugins and I’m not sure it’s been entirely weeded out yet.

This helped me a lot. I have had a same problem and it was caused by OneDrive issue in my case. Robert led me to your article. Thank you very much.

1 Like

yes. everything on windows fails to deal with paths that have non-ascii characters in them. I used to test all my module for this, with a folder name I made just for this purpose. Also, that bug is so common I’m surprised you haven’t had problems with other software. Even though this “should work” it’s still asking for trouble to name your main windows account with a non-ascii character in it.


1 Like

It is, nevertheless, still a bug in the plugin that should be reported to the plugin author. Please open an issue on their github.

Rack itself, I think doesn’t have the issue. If a plugin author finds that it’s a bug in Rack (or rack dependency), then the plugin author can port the bug over to Rack.

It’s unconscionable for developers to tell users they have to spell their names with ASCII in 2023. If a plugin author needs help figuring to how to properly use Unicode, they can ping me and I’m happy to help.