Lag adjusting VST/AA parameters while using Monome Teletype (VCV)


I’m using the Monome Teletype VCV module in VCV Rack 2 Pro (latest) and I’m running into an issue where anytime I use the VCV VST in Ableton Live 11.1 (MacBook Pro M1) various plug ins and Ableton parameters become almost unresponsive or there is a huge lag when attempting to adjust parameters. Has anyone else experienced this problem and what was the resolution. Even when I run VCV Rack 2 Pro in standalone I run into problems with the Monome Teletype. It’s kind of a bummer because I’ve been enjoying learning how to use the module. I appreciate any input you have. Thanks.

What problems do you observe with Teletype in standalone Rack? Teletype hasn’t been tested with a M1 and since it uses some dlopen shenanigans it would not be surprising if it acts strangely under Rosetta.

Actually it has been tested with a Mac Mini M1. I’ve built and tested your repo successfully for x86-64 and aarch64.

1 Like

Thanks Dave, I should have said I haven’t personally tested on M1 hardware. I would not be surprised if an aarch64 build behaves better than x64 running on Rosetta.

Bottom line, Rack Pro VST support for this plug-in is merely provisional at this point and M1 in either Rosetta or native form is not officially supported. Feel free to file GitHub issues with your specific observations. If anyone wants to send me some M1 hardware that would speed things along :slight_smile:

1 Like

Teletype in VCV Rack 2 Pro no longer works on my M1 Macbook Pro. As I’m still learning to write scripts, I was doing something in the metronome and it triggered the scripts I had written which much have been something that required heavy processing because everything came to a halt and Teletype stopped working. I can click in the window where scripts are written but all I get is the yellow border around it; I don’t get an option to type in scripts, nor can I TAB through the different windows. I deleted the plug in and reinstalled it but that didn’t do anything to fix the problem, so I’m not sure what to do about that. It didn’t affect the ability to use Teletype when I use VCV Rack 2 Pro as a VST in Ableton 11.1.

Sounds like you need to clear your patch; it’s possible that you’ve created an infinite loop in your script. If you can attach your patch to this issue that would be very helpful.

(Standalone and Pro VST have different auto load patch locations, which is probably the reason that the VST is unaffected.)

@Dewb Maybe you can offer some advice because I’m not sure how to go about fixing the issue I have. VCV 2 Rack Pro (standalone) will no longer work. A patch will load but i can’t get clocks, LFOs, buttons, etc. to do anything. This all happened after Teletype got wonky on me. I’ve deleted Teletype and reinstalled it, deleted VCV 2 Rack Pro and done the same, but nothing I’m doing seems to work. If anyone has any suggestions I’d appreciate it. I’m on an M1 Macbook Pro with the latest OS. I can still use VCV 2 Rack Pro as a VST in Ableton and it works fine, but I’d like to get the standalone working properly again. Thanks.

That’s often a symptom of not having an audio device selected.


What @PaulPiko said—if all modules in a patch aren’t executing, the first thing to check is whether you have an audio device selected. This catches me too, sometimes, still; it’s easy to forget!

As I said above, my advice is to share the patches that demonstrate the problems you’re having; without direct access to your computer, you’ve got to give us something to work with.