Knobs jump in VCV 1.0 (resolved in latest rack commit / next update)

Not sure where I should be reporting issues, but here’s one. In the new version, sometimes when I click a parameter (knob/slider) the value will quickly swing to one end or the other and then I have to quickly adjust. This never happened to me in the previous version. I can’t find anything common about when it happens. Anyone else experiencing this?

Other than that, am loving v1, thanks!

On github: https://vcvrack.com/manual/FAQ.html#i-found-a-bug

1 Like

Submitted on Git, thanks @dag2099

1 Like

I’m noticing this quite a bit, and it’s ruining my workflow. I’m on Windows. I think it might be related to adding the MIDI Map module to a Rack. Is that when it’s happening for you as well?

it happens to me without the midi map module as well

ditto, no MIDI map module added. and the effect on workflow is huge, agreed!

This has happen a lot to me but I am not able to reproduce it. If you guys know a way to reproduce the bug please share it.

yep cosign - I’ve been experiencing a bit of this as well on windows 10

I think it occurs way more often when the cursor is moving quite fast just before clicking on the knob

Unfortunately, Andrew Belt cannot reproduce the problem which leaves those of us suffering with it tripping all over our knobs.

By any chance do any of you who have also reported the issue use a Logitech mouse? Are all reporters on Windows 10?

Turning off “Lock cursor while dragging” in VCV Rack fixed the issue for me. I am on Windows 10 and am using a Microsoft Bluetooth mouse.

I don’t think that is a ideal option. For knobs that are near the edge of the screen, your cursor readily runs out of room.

I have this issue too, here with a sharkoon “shark force” mouse on Win10 on my PC and
with a Logitech mouse on Win10 on my laptop too.

Ah, that could be. I work on small racks on a laptop so haven’t really had that issue. Can see how it would be a problem though. Hope they can figure out an actual fix for it eventually.

I had the same issue running Rack v1.0 on Windows 7. I reduced the frameRateLimit value in the settings-v1.json file and it solved the problem for me.

I have this problem on my laptop with win 10 as well. Both with touchpad and usb mouse.

I’m not sure if I have detected a pattern, but I feel like the value jumps if I click on a knob and immediately begin dragging. If I click on a knob and hold the mouse stationary for a bit, the value “possibly” does not randomly jump. I’ll have to play with it a while to see if this is really the case.

If so, good, although my wrist will ache from the concentrated effort of holding the mouse stationary over and over with the mouse button depressed.

EDIT: No, this does not seem to be the case. Values still jump randomly. :frowning:

I lowered the frameRateLimit from 70 to 20. Made no difference.

yes that is what i experience as well, if i hover above the rotary knob momentarily before turning i can reduce the jumpy behaviour.

Cosigned.

Win10Home, Logi M570 trackball using Setpoint. "frameRateLimit": 30.0, "frameRateSync": true,