Is there a VCV bridge that works with ableton 10 and OS catalina?

I still can’t get a stable result with Stellare link) At least with Clocked module, especially with the last version

The trick is to use the BPM outputScreen Shot 2020-06-04 at 12.11.01

But this video explain the way to do in windows, but I have mac, I don’t have this asio

this kind of set up doesn’t works pretty well i think but thank you so much

What issue do you have with it ? it works perfect for me, even more reliable than using an audio clock which is what I used to do.

OK - here it is step by step in detail on Mac

  1. Create an aggregate device (Using Audi Midi Setup application) with built in output (or your interface if you have one) which you will use for monitoring and Blackhole which you will use for sending signals between Live and VCV. This gives a device with 18 outs and 16 ins

  1. In Live audio preferences, set your input device to Blackhole and your output device to your aggregated device (I called mine Built in + Blackhole)

  1. Configure your input settings - how you configure these is up to you - I set up the first 8 inputs as mono and the second 8 as stereo

  1. Configure your output settings - Here I have outputs 1&2 as stereo (for monitoring) and outputs 3&4 (which are for the clock and transport) as both mono and stereo (reason for that in a moment). You can configure more outputs here if you want to send other audio from Live to VCV for processing.

  1. In Live, create an audio track and add the CV Clock out device. Set is as below - 24ppqn and use External out 3 for Clock and External out 4 for the run trigger (this is why we need 3&4 as mono).

CV clock settings

  1. Configure the track settings as below so that the clock device outputs to External Outs 3 & 4 (this is why we need outputs 3&4 as stereo too).

  1. In VCV, set Blackhole as your device in Audio-16 module. Connect the “From Device” jack 1 to the BPM input of Clocked. Set the 'From Device jack 2 to the Run input of Clocked.

  1. Click the Mode + button on Clocked until it says P24

That’s it - Live and VCV should be perfectly synced and VCV transport is controlled from Live.

1 Like

Ouch great explication thank you so much Steve, I will try when I have a little time!! :smile:

sorry, I tried step by step and for me doesn’t work, It doesn’t arrive clock to vcv rack below I show you the pictures with the setup.

Screen Shot 2020-06-11 at 5.24.15 AM

Hmm strange - all seems wired up correctly.

On your 1 Audio track, try changing Ext. In to “No Input”.

Are you sure VCV has permission to use the microphone? If it does not you will not get any incoming audio. Go to System Preferences > Security and Privacy > Privacy tab.

Select microphone in list on left. Make sure Rack is checked and allowed to access microphone. If it is already checked, uncheck it and check it again.

why are you using 1\2 cables ports in vcv while you have selected 3 and 4 outputs in ableton CV tools itself?

Because in Ableton he is using an aggregated output device of his built in audio (outputs 1+2 for monitoring) plus blackhole (outputs 3+4 for clock and transport). Outputs 3&4 are the first 2 Blackhole outputs.

In VCV he is just using the blackhole input device. So outputs 3+4 in Ableton are inputs 1+2 in VCV.

My money is on his issue being Rack microphone access.

1 Like

you are the best !!! I got, thank you so much :smiley:

1 Like

Great - was Microphone access the problem?

Not sure why you keep removing your post about 7 bpm difference in tempo?

I can’t explain it though - for me tempo is perfectly aligned - if 90bpm in Live then also 90bpm in VCV.

Because I fixed it, it had different bit depth on both. but the problem i have now is that when i press play in ableton they are never synced, i set the ableton preferences latency but when i press start again it is out of sync again, how can i fix this problem?

When you say you set Ableton preferences latency - would do you mean exactly? I think there is only midi latency in preferences.

OK so I was expecting you to come back with this question about latency :slight_smile: Didn’t want to confuse things too much at the start.

I generally use Silent Way sync rather than CV Tools clock and expected them to be about the same - but it seems CV Tools clock does give me a lot more latency than Silent Way for some reason… anyway - here is how you fix it…

You need to use the Ableton External Audio Effect module and place it BEFORE the CV Clock out.

Set Audio To > No Output

Set Audio from - whatever channels you are using to receive audio from VCV - I’m using 9/10

Set hardware latency amount such that they are in sync each time you stop/start - for me it is about 180ms which is A LOT. And this is with a block size of 128 samples in VCV and Live. I’ not sure why latency is so high but combination of CV Tools Clock, Blackhole and VCV Buffer I think…)

Here’s my audio going from VCV going out on 9 and 10

You could also use a midi track rather than an audio track for the clock, and use an External Instrument rather than external audio effect before it - this would allow you to send midi to VCV.

ok, i have silent way, can you explain me the setup with this plugin? are you using midi or audio? thank you so much

I think with the external audio effect doesn’t work, the clock of vcv turns crazy, 128 buffer size is too small and makes glitchy, maybe I did something wrong but it is very difficult to make something wrong with your explanation. I don’t understand what I did wrong. I have silent wave sync, can you explain to me the way you use, it works for you, should also works for me. thanks for all the explanations, and for the time you have wasted with me

Depends on your computer i goes but I get best sync with buffer size of 128 in both.

Not sure why External audio effect would make clock go crazy in VCV - it should have no effect on the clock in VCV at all - all it does is allow you to compensate for the latency by delaying Live’s playback.

Anyway here is the Silent way method. It’s very similar to CV Tools method. There is an instrument and an effect version of the Silent Way Sync plugin - you can use either. In this example I have used the instrument version on a midi track. I have then added the External Audio Effect after it. You have to use the External Audio Effect as it is the only thing that compensates for the latency.

Difference compared to CV Tools is with SW Sync I only need to add 36ms hardware latency compensation rather than 180ms!

In Clocked right click menu in VCV - ‘On Stop’ check both ‘do internal reset’ and ‘send reset pulse’.

Also check “Run CV input is level sensitive”

Also in Live, make sure, under Options menu, that ‘Delay compensation’ and ‘Reduced latency whilst monitoring’ are checked.

1 Like

huge steve thank you so much, really works, it’s not like bridge because is more fast to set up and more exact with the tempo but works very good thanks

1 Like