I had the most amazing jam last nigh, but this morning, Rack won't open.

I always check for != null before doing anything with it.

You’ve all lost me now. At some point if a solution of sorts is found, if someone could ELI5?

A work around would involve perhaps opening the save in a text editor and knowing the module source code in detail to make the extra stuff it isn’t finding. Typing it in, save, and maybe …

The problem is in the RPJVisualizer, most likely due to a newer version trying to read the json written by an earlier version.

I’m not sure what the workaround would be for this.

Hi Dave they are working on a solution, there is nothing more for you to do at this point :sunglasses:

I am a bit confused why the problem still exists. So I asked to remove the module as @Yeager suggested. When you open a patch containing the module you should get a message the module is missing. When you continue the patch will load without visualizer. At that point you can add the module again by installing the updates. Restart and you should be able to add the module. Json will be written with latest version json.

Doing nothing is the hardest thing to do! :slight_smile: Thanks Peter

1 Like

Well Robert gave you a new assignment …

Yes I did :slight_smile: Of course I will look into the null issue too (tomorrow) but I hope you can get back to me on the assignment :slight_smile: Or one of the others to explain where my thinking goes wrong.

Sorry, was replying to Peter and missed this - but I did do this already. So with the plugin removed, I do get the error message that it’s missing. In the library tab it shows that it’s available RPJ Visulaizer 2.1.10. If I Update All and do the restart… huh. This time it worked but RPJ is not there. Ah I see. I have to save it like this and then re-insert the new module - duh. Same with a couple of other patches. Works, great stuff! Thx very much!!


Yeah that worked in development of my own modules too when I made an error of a kind. Lucky VCV can be non critically restarted, phew!


Case 1 …

Screenshot 2023-01-21 23.44.14

Case count: 1

Case URL: I had the most amazing jam last nigh, but this morning, Rack won't open. - #38 by jackokring

How solution?

Ah yes, I forgot to mention you had to save, glad you found out yourself. Good to hear it is working again.

OK, I checked my code and you were closest to the cause of this issue. What has happened? In the old version 2.1.6 (as the log showed us, that was the version of the module used in the saved patch) I had a variable written to the json called activePreset. The type was json_integer, In a later version, I changed this activePreset from integer to string, keeping the name in the json the same (stupid me). So, trying to read a string, where actually an integer is stored causes vcv to crash. Tried this by replacing the string in my autosave/patch.json to a value.

Let this be a warning to others.

no, I think I was right. The condition you described happened, that caused the json function to return null. The fix is to check for null.

Yes, you are 100% right. The read is ok, the assigning goes wrong because of the NULL value. Credits to you Bruce :wink:

1 Like


This is probably an important warning to heed. I say this because I have fallen victim to this issue before in my plugin/module. Anyone who overrides dataFromJson() is vulnerable to this unless they check for null on each data object.

Yeah, Bruce gets credit. I was just the cheerleader :wink:


Here’s your patch recovered without the RPJVisualizer. Now it should load.

DARK-Ambient-recovered.vcv (11.0 KB)

1 Like

Appreciate the gesture but I did get it worked out :wink: