How do you resolve Could not load patch: Unarchiver . . . error

How do you resolve the Could not load patch: Unarchiver could not write file to dir: Could not unlink error when opening patches in VCV Rack 2.0.3 (Windows)?

image

Search before posting please. About 10 other people have reported that in here, and probably another 20 of Facebook. I’m sure it’s being looked at. In the meantime check the usuals: No Documents folder on Onedrive or Dropbox. No strange anti-virus programs.

reply to @rbnicklas

One wrote that there were read-only files and/or folders. They had to change the persmissions to get it working.

browse to documents, right-click Rack2 and remove the mark in “Read Only” - then click “Apply”

image

2 Likes

It will be nice when VCV 2.xy gets debugged enough that we don’t get the same 2 or 3 bugs over and over!

Jens,

Thank you for responding.

Unfortunately, changing the read-only protection on the VCV Rack 2 folder did not resolve the issue, for me I notice that the VCV Rack folder (version 1.*) has a similar protection, yet it does not throw an error.

I suspect (and I’m only guessing) that the issue is related to parsing the VCV file on input… I did not encounter the error while using the initial VCV Rack 2 release, but only after upgrading to v 2.02/2.03.

Hopefully, the condition that causes the error will be identified and we’ll read about the solution in this forum.

Thanks.

It solved a problem for somebody else. I don’t know enough to conclude anything.

You could delete everything in documents/rack2 and reinstall rack2.0.3

But if you use ransomware protection, you would still get errors, if you didn’t add the Rack executable to the “allow” list.

Not sure the devs can solve all install errors - but it would be nice if a filename was giving on the “unlink” error, to narrow it down.

1 Like

Interesting Jens. Is this “Ransomware protection” a new feature in Windows, that thinks it’s a good idea to make people’s files read-only? That would be… interesting.

I wonder if Rack is treated as unknown/unfriendly because it doesn’t have a code signing certificate, so can’t write there. That’s just a suspicion, I haven’t tested that myself. If I get a chance I’ll try it with my code signing certificate and see what happens.

I haven’t read the details, I usually just turn it off.

Controlled folder access is supported on the following versions of Windows:

Windows 10, version 1709 and later
Windows 11
Windows Server 2019
Windows Server 2022

Windows system folders are protected by default, along with several other folders:

c:\Users\<username>\Documents

etc.

You could probably explicitly choose to let Rack get to the controlled folders

If “protection” on c:\Users<username>\Documents means “we’ll make your files read-only”, that sounds insane. The definition of documents is literally that the user will be writing files. Oy vey… sometimes Microsoft really looses the plot. Prepare for a deluge of user complaints for all manner of software that won’t work because of this and they have no clue why if it’s engaged by default. Yikes.

Could be, if that “Ransomware protection thing” takes that into account. But still, make people’s document files read-only to protect them against themselves is just untenable. But yeah, if this is the new norm it could force Rack into being more signed, more “approved”, etc… It’s a brave new, awful world.

Only MS verified programs can write to Documents when Ransomware protection is turned on. How you get to be verified is another question… It’s not directly related to code signing, I tried that. But you can explicitly trust a program, and then it can write to Documents (see the image in my previous message). That would be the way to do it if the user wanted to keep Ransomware protection turned on.

Windows security also keeps track of unauthorised attempts to write to Documents, and they’re shown in Protection history. You can allow the program by following the associated link

image

Yikes! I guess this ransomware protection thing is relatively new, otherwise we would have heard a lot about this before. And yeah, it sounds like Rack Windows users are going to be bitten hard by this, if they don’t know what’s going on. @Vortico definately needs to put this in the installation steps for Windows, until the situation might be sorted. But jeez… most people won’t know this is turned on by default, and will have no clue why their programs stop working.

This could cause issues for any program developer. The Documents folder, and Pictures, Videos, Music and Favourites are the usual place to store data for the user, and it has been the recommended practice for as long as those “special” places have existed. I’ll have to investigate this, hopefully before anything of mine gets blocked…

1 Like

Ransomware protection may not be turned on by default, unless the default has changed recently

1 Like

But I still need to check what Win 11 does by default

@rbnicklas It would interesting to hear from you:

  • If the ransomware protection thing is turned on, on your computer.
  • Whether it was turned on by yourself manually or if it was just turned on automatically, after a Windows update.
  • What Windows version you’re using, 10, 11, Home edition, professional edition.
  • Whether it’s a personal, stand-alone computer or it’s enrolled into an organization/domain.
  • Whether adding Rack to the approved list, as Jens Peter demonstrates above, solves your problem.
1 Like

I think you mean the screen shot I posted :wink:

Either that way, or the “allow an app…” on the screenshot Jens Peter posted.