Has Anyone made Code Nav tools in CLion work


So about 2 years ago I switched to CLion and it is amazing. The code navigation and refactoring stuff is incredible.

It relies pretty heavily on CMake or on a fairly standard makefile setup though, and I haven’t been able to make it work with VCV Rack, especially on an M1 mac. Most notably I can’t make code completion, typeahead, hints, etc… work at all.

Has anyone done this? I looked around and there was a 1.1.6 posting from @qno using conan but nothing in the last couple of years. And if not CLion, anyone set up the code completion / hints with VSCode?

All I want is for all of nanovg to be there on typeahead for me in clion. But with a combo of M1, makefiles, rack not supporting arm, and more, it’s tricky.

Thanks for any help.

I’ve got my plugins building in CLion (Intel Mac)… I haven’t tried anything too fancy with refactoring or anything, but basic completion and “Go To Definiton” kind of things are working.

I don’t think I had to do anything special to get it working, but I do remember looking at this article from the JetBrains website.

In case it helps, here’s my “Preferences” settings:

And Debug configuration (I don’t think I’ve tried setting breakpoints, but log messages come through):

Right - I wonder if I need to restart CLion under Rosetta for it to work? Thanks!! I’ll try these settings and that approach

So just in case anyone else with an M1 mac comes along and has a question, I was able to make CLion work perfectly, but to do it I had to write a fake CMakeLists which does my build and then as a post build command runs the actually install. That means al my clion tooling works as if it is a normal cmake project and the makefile build still does the install, at the cost of building twice on every change in my IDE, but my computer is fast!

I added proper CMake support for building SurgeXTRack plugin.

See build SurgeXTRack with CMake by qno · Pull Request #709 · surge-synthesizer/surge-rack · GitHub

1 Like

This is very exciting. As I said on GitHub, thank you very much! I’ll review it before the weekend. Really appreciated!

I did something similar, just a CMakeText for CLion indexing etc. and for building I run an external build-script switching to x86_64 mode…works perfect for me and I love JetBrains IDEs :slight_smile: