Getting „can‘t unlink object“ error on saved patch load

After following the guide and uninstalling Rack 2 dev builds and deleting user and install folders I still get the error when trying to load a saved patch. Saved with the newly installed VCV btw :wink: Any idea what the problem is?

EDIT: attached log log.txt (35.0 KB)

Still getting the error after updating to 2.0.1.

Windows / Mac /Linux ?

First, make sure you have a backup of your own work, patches etc. - then try deleting everything in documents/rack2/* before starting Rack2

  • Is documents/Rack2 on a path with International characters ? That may not work.
  • Is documents/Rack2 on a path managed by OneDrive ? That may not work.

If on Mac/Linux:

  • what’s in /temp/Rack2
  • try deleting /temp/Rack2/*

or DropBox.

This appears to be a module related problem. I get this error with a subset of Nysthi modules, such as the Envelope Follower and the Simpliciter modules, but not with others. I’ve posted a bug report to the Nysthi github.

Does it happen if you use no NYSTHI modules? (or is the other poster having a different issue?).

I’m on windows and no intenational characters nor one drive installed. As mentioned i deleted user and install folder. Funnily i can open the patches when i run Rack 2 as administrator. Does that ring any bell?

sounds like permission issue

Yes, sounds like it. But i don’t know what’s going wrong here. No errors in the log file either.

did you install version 2 0 10 ? no report admitted if not coming from 2 0 10

Posting here as well for visibility: updating the module package fixed the problem, and modules are now saved correctly as VST presets.

Sadly not for me. I tried reinstalling and running with disabled Windows Defender. Still doesn’t work. I added a log to my original post. I don’t see anything suspicious.

After reinstalling about ten times it works. No idea why.

This worked for me: VCV can't load patch

Some small number of people have had this problem. So far no one seems to know the cause.

I got a message from support, that the problem is solved in the next release. Thanks @Vortico