Getting a write error when updating to 2.2.1

At the point in the install when the VST3 is being installed I get a write error and have to abort the install. This was after a fresh reboot and Rack had not been run. Is there an install log somewhere that I can browse to see if there is more to the error message??

I have reinstalled 2.2.0 with no problem

Operating system and version? Did you close all your DAW’s before running the update? Also, check the task manager and verify that no Rack processes are running before the update.

In WIndows: Check to see if you already have a file “VCV Rack 2.vst3” in c:\Program Files\Common Files\VST3. If you do, delete it. I found the installer tries to create a folder with the same name and can’t if the file is there.


Thanks for posting this. I ran into this issue just now but had also just seen your post. This saved me some grief.

1 Like

Unfortunately, the first time I tried to update, I chose “Ignore” instead of “Abort”. I followed the advice from @PaulPiko, but now it refuses to even try to install the vst3 file, even though I deleted the old one. I even tried uninstalling VCV Rack Pro and re-installing it, but still no dice. This is on Windows 10. Anybody else have this problem?

Edit: Why didn’t I have this problem when I installed v2.2.0 a few weeks ago? Did something break in the install procedure?

I had the same issue on Win10. Also, chose ‘ignore’. I was able to uninstall/reinstall fine and didn’t have to remove any previously installed plugins (which I was a little concerned with because I have a bunch that aren’t in the library).

Weird that it didn’t work for you.

I believe that I did reboot after uninstalling because I suspected Studio One may have been what wasn’t allowing replacing the vst3. This is only speculation, however.

Thanks…deleting the VST3 file worked for me

1 Like

I have many other plugins in the VST3-folder, so i do not want to delete the folder. Abort 2.2.1 installation, then uninstall/reinstall VCV-rack worked for me.

No oner said to delete that folder. Delete a file within that folder.;

This post just saved me an unnecessary panic attack. Just updated to 2.2.2 and the VST3 stopped working. So rebooted, uninstalled and reinstalled. And all seems fine now. Thank you.

I hope you’ll report this to, it’s quite a serious upgrade bug that will bite a lot of people. Thanks.