Endless module update loop at "Menu > Library > Updates"

Hi,

I have just purchased VCV Rack 2. The installation went well. Updates are showing for some modules (red dot). When I start the updates, they seem to be downloaded… the percentages count up. However, after restarting, the same modules show up again as updates. I have done this 4 times now… always with the same result.

Thanks for help!

–– I’m on MacOS 10.14.6 (Mojave)

I had installed VCV Rack 2 as an update from the menu over the beta. Maybe that was the problem. The VSTs were not there either and the installation process did not ask for an installation location for them.

This workaround worked for me now and only with the standalone version:

  • uninstall Beta
  • download VCV from the website
  • install / log in
  • the plugins from VCV 1 are there (of course only those that are already prepared for VCV 2)
  • VSTs are there

Maybe this helps someone.

2 Likes

I must say I still have this when I run multiple instances of VCV in VST mode. Almost like it saves the library update status from within the VST. Every single instance of the VST has different modules to update, but also updates that I just did in another instance of the VCV VST.

How exactly did you uninstall the beta?

Thanks

I uninstalled it with the AppCleaner

1 Like

Okay wait… I have the same problem in VST mode. I have just started experimenting with the VST mode. My initial post was about the normal VCV Rack. I also have problems with the login. I can only log in to VST mode if I have previously logged out of normal mode. After logging in, I have to re-download the modules, but they disappear after the next time I open the VST. Also, selections that I created in normal mode do not work in VST mode. There, selections always open with only one module… VSV’s “Audio”.

  • MacBook Pro M1 Max
  • macOS 12.1
  • VCV Rack 2.0.4
  • Bitwig 4.1.2

Aha. I actually thought you were talking about the VST mode. I also still have that. Can you ask support about this?

I also use Bitwig and the VST. Maybe Bitwig is saving the state of the plugin’s library?

I tried uninstalling, then do a completely new install, and first update all the plugins from the stand-alone version.

After installing all plugins, I open a Bitwig Project with VCV VST’s and there are all the plugins waiting for the same update I just did in the stand-alone version.

Now I don’t touch the update in VST mode anymore, but not sure if that helps yet.

I contacted the support who responded very quickly and kindly. Here only the most important:

This is a known bug and we are hoping to fix it in the near future.

I suggested pinning a list of known bugs at the top of this subforum. This would potentially save a lot of trial and error for affected users and support requests. I don’t know if that would make sense from VCV’s point of view. Just an idea.

2 Likes

Thanks so much for this! Finally found this thread after installing last night. In standalone everything is peachy. Running as a vst…No love. Only the 12 core modules and perpetual login and updating cycle as well. GLAD TO HEAR THEY ARE ALREADY ON TOP OF IT!

For now, just update the VCV in stand-alone. After that open VST and ignore updates there.

1 Like

Many thanks I’ll give that a go.

EDIT: Gave that a go and still only the Core modules are showing. I have to delete the fundamental file a couple times to be able to login into the VST.

There was some kind of update to fundamental this evening. I uninstalled everything. Shut down. Reinstalled. And Now I can see all my modules inside the vst in ableton 11. Yes!!!

it would be crazy, but they could have a searchable online database of bugs. Oh, never mind, that was for 1.0.

What version is this that you have updated to now? I’ve had 2.0.4 from the developer section installed for a week or so and I don’t see a new update. Also the problems are not fixed yet in my version 2.0.4.

1 Like

I purchased on Christmas and was running 2.04 as well. Around 5pm a fundamental update popped up in the library. Now I have access to all library modules in The vst version.

That’s the only thing that I saw that may have allowed me to see all lib modules

Okay, thank you! Just to be sure: The fundamental update was shown in the library dropdown in the standalone version?

There is not a single update for me, I do not know how it is for others. In the VST I just updated everything that was there. After that all updates appeared again and the loop starts again. Same same…

Also, every time I add VCV as a new instrument (Bitwig), I have to log in again. But it doesn’t accept the login until I open the standalone version in addition. However, that may be a different issue, but could also be related.

I wonder if it’s having trouble writing to the user directory when it’s running under bitwig.

Yes, this could be a permissions issue… at least on Mac. I just gave Bitwig full disk access. Now all plugins are there and the update loop has an end. The login requests don’t seem to occur anymore either. Good hint! It does weaken security, but it works.

1 Like

You got it. From the dropdown. Took a few tries in the standalone and vst.

Then I decided to delete all non VCV modules from the site. Uninstall standalone, delete documents rack file, vst’s and anything that had some kind of log with vcv. I also double checked for any hidden rack 1 stuff. Emptied Trash and shut down the Mac. Reinstalled then updated standalone then went ahead and tried updating via the vst and that even worked as well.

Took me several uninstalls and reinstalls over the weekend and it seemed anytime I was having login issues with the vst if I deleted fundamental I would be able to at least log in. but so far it appears to be fully operational now!

Thank you, for the detailed info. Sounds pretty thorough how you did it. The problem in my case was apparently access rights. I have no idea whether this is generally solved by giving the DAW access to the entire hard disk, or whether the VCV developers will make some adjustments so that this is no longer necessary. At the moment everything works for me, as far as I can see.

1 Like

From the description of your symptoms, I think permission to Rack’s user directory would be enough. But I’m not a Mac user, and it’s really only an educated guess