DanTModules New Releases Thread [Working towards V2]

v1.2.3 of the DantModules plugin has been pushed to the Library

Changelog

This is mainly a visual update to improve the look of the modules, hope you like it.

But there is also a tiny addition to WAVULIKE to show the exact frequency in the context menu as this can be useful for things such as Jakub Ciupiński’s aliasing trick

11 Likes

pretty nice. a small tip: on your tooltips they “jump around” a lot as they go to different numbers of decimal places. It looks a little nicer if pick how many places you want to show and do that consistently, possibly adding zeros if necessary. Of course the C runtime makes this very easy.

Published a new Windows V2 Preview build on the manual page (built for 2.git.b04e4117)

1 Like

Published the next new Windows V2 Preview build on the manual page (built for 2.git.b04e4117)

This one is a bit special because the TMNT module has some feature upgrades; it now has CV trigger inputs for the manual step buttons, and it has a button and CV trigger input to randomise the steps.

The newest preview build is up for 2.git.042a9ce0 and it fixes two known bugs :grin:

Whoo, Hoo!

Fixed all currently known bugs for V2, so ready to go for release unless new bugs are found.

Hopefully this means I can either add some new features to the modules, or maybe even finish off some of the experimental modules I’ve been working on for the official release.

In the mean time the bug free V2 windows build has be posted.

2 Likes

Bug free. Brave words!

I can’t extract it on my Win10, I get a message “Unrecognized archive format”

You shouldn’t need to extract it, it should download as the vcvplugin format, you just put it in your plugins directory and start VCV Rack 2 and it will extract it for you

thats exactly what I did,
and I get the message when I want to run v2 from my mingw64 with the “make run” command,
then I get the “Unrecognized archive format” message in mingw64

Are you building Rack from source? If so are you using the correct version 2.git.042a9ce0

I haven’t built rack from source, I am just using the build @Vortico provided here

It’s working here with the prebuilt 042a9ce0

I just did a new build of Rack version 2.git.042a9ce0
and I still get the same error

Do other vcvplugin files get extracted?

Have you tried using the prebuilt version?

I’m not really sure how I can help out, it seems that the issue stems from the building of Rack currently.

How are you downloading the file from github? Maybe there is something going on there.

Maybe you could try opening the archive directly, ie: reversing this part of the makefile tar -c $(SLUG) | zstd -$(ZSTD_COMPRESSION_LEVEL) -o "$(SLUG)"-"$(VERSION)"-$(ARCH_OS_NAME).vcvplugin

I just did a new build of Rack version 2.git.042a9ce0

Did you also download the new 2.git.042a9ce0 version of the SDK? My understanding is that both the app and the plugin need to be built against the same version

I found the issue:
I downloaded it from your github manual page via

  • right mouse click on “DanTModules-2.3.4-win.vcvplugin (built for 2.git.042a9ce0)”
  • “save target under …”
  • then I get a “DanTModules-2.3.4-win.vcvplugin” file with just 144kb

but when I

so maybe the linking on the github page is somehow wrong?

1 Like

Ok good to hear you got it working, yes it sounds like a github thing, when i click on the link it shows me the file in the repo, and then there is a download button. If anyone knows of a better way to link to a repo file in markdown i’ll happily change it.

I think making a “release” is the “right” way, yes?

Well maybe for a repo where you build the code, but this is just my manual site and a single preview page with links to files that I have added to the repo, does a release make sense in that context?

Oh, good Q. It does let you add arbitrary binaries, so probably good? But yes, a little different for you.